HZ(9) BSD Kernel Developer's Manual HZ(9)NAME
hz, tick, tickadj, stathz, profhz -- system time model
SYNOPSIS
#include <sys/kernel.h>
extern int hz;
extern int tick;
extern int tickadj;
extern int stathz;
extern int profhz;
DESCRIPTION
The essential clock handling routines in NetBSD are written to operate with two timers that run independently of each other. The main clock,
running hz times per second, is used to keep track of real time.
In another words, hz specifies the number of times the hardclock(9) timer ticks per second. Normally hardclock(9) increments time by tick
each time it is called. If the system clock has drifted, adjtime(2) may be used to skew this increment based on the rate of tickadj.
The second timer is used to gather timing statistics. It also handles kernel and user profiling. If the second timer is programmable, it is
randomized to avoid aliasing between the two clocks. The mean frequency of the second timer is stathz. If a separate clock is not avail-
able, stathz is set to hz.
If profiling is enabled, the clock normally used to drive stathz may be run at a higher rate profhz, which is required to be a multiple of
stathz. This will give higher resolution profiling information.
These system variables are also available as struct clockinfo from sysctl(3) and kern.clockrate from sysctl(8). The hz is hardware-depen-
dent; it can be overridden (if the machine dependent code supports this) by defining HZ in the kernel configuration file (see options(4)).
Only override the default value if you really know what you are doing.
SEE ALSO adjtime(2), callout(9), hardclock(9), microtime(9), time_second(9)BSD March 25, 2010 BSD
Check Out this Related Man Page
EVENTTIMERS(4) BSD Kernel Interfaces Manual EVENTTIMERS(4)NAME
eventtimers -- kernel event timers subsystem
SYNOPSIS
Kernel uses several types of time-related devices, such as: real time clocks, time counters and event timers. Real time clocks responsible
for tracking real world time, mostly when system is down. Time counters are responsible for generation of monotonically increasing time-
stamps for precise uptime tracking purposes, when system is running. Event timers are responsible for generating interrupts at specified
time or periodically, to run different time-based events. This page is about the last.
DESCRIPTION
Kernel uses time-based events for many different purposes: scheduling, statistics, time keeping, profiling and many other things, based on
callout(9) mechanism. These purposes now grouped into three main callbacks:
hardclock() callout(9) and timekeeping events entry. Called with frequency defined by hz variable, usually 1000Hz.
statclock() statistics and scheduler events entry. Called with frequency about 128Hz.
profclock() profiler events entry. When enabled, called with frequency about 8KHz.
Different platforms provide different kinds of timer hardware. The goal of the event timers subsystem is to provide unified way to control
that hardware, and to use it, supplying kernel with all required time-based events.
Each driver implementing event timers, registers them at the subsystem. It is possible to see the list of present event timers, like this,
via kern.eventtimer sysctl:
kern.eventtimer.choice: HPET(550)LAPIC(400)i8254(100)RTC(0)
kern.eventtimer.et.LAPIC.flags: 15
kern.eventtimer.et.LAPIC.frequency: 0
kern.eventtimer.et.LAPIC.quality: 400
kern.eventtimer.et.i8254.flags: 1
kern.eventtimer.et.i8254.frequency: 1193182
kern.eventtimer.et.i8254.quality: 100
kern.eventtimer.et.RTC.flags: 17
kern.eventtimer.et.RTC.frequency: 32768
kern.eventtimer.et.RTC.quality: 0
kern.eventtimer.et.HPET.flags: 7
kern.eventtimer.et.HPET.frequency: 14318180
kern.eventtimer.et.HPET.quality: 550
where:
kern.eventtimer.et.X.flags is a bitmask, defining event timer capabilities:
1 periodic mode supported,
2 one-shot mode supported,
4 timer is per-CPU,
8 timer may stop when CPU goes to sleep state,
16 timer supports only power-of-2 divisors.
kern.eventtimer.et.X.frequency is a timer base frequency,
kern.eventtimer.et.X.quality is an integral value, defining how good is this timer, comparing to others.
Timers management code of the kernel chooses one timer from that list. Current choice can be read and affected via kern.eventtimer.timer
tunable/sysctl. Several other tunables/sysctls are affecting how exactly this timer is used:
kern.eventtimer.periodic allows to choose periodic and one-shot operation mode. In periodic mode, periodic interrupts from timer hardware
are taken as the only source of time for time events. One-shot mode instead uses currently selected time counter to precisely schedule all
needed events and programs event timer to generate interrupt exactly in specified time. Default value depends of chosen timer capabilities,
but one-shot mode is preferred, until other is forced by user or hardware.
kern.eventtimer.singlemul in periodic mode specifies how much times higher timer frequency should be, to not strictly alias hardclock() and
statclock() events. Default values are 1, 2 or 4, depending on configured HZ value.
kern.eventtimer.idletick makes each CPU to receive every timer interrupt independently of whether they busy or not. By default this options
is disabled. If chosen timer is per-CPU and runs in periodic mode, this option has no effect - all interrupts are always generating.
SEE ALSO apic(4), atrtc(4), attimer(4), hpet(4), timecounters(4), eventtimers(9)BSD March 13, 2012 BSD