Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

hardclock(9) [netbsd man page]

HARDCLOCK(9)						   BSD Kernel Developer's Manual					      HARDCLOCK(9)

NAME
hardclock -- real-time timer SYNOPSIS
void hardclock(struct clockframe *frame); DESCRIPTION
The hardclock() function is called hz(9) times per second. It implements the real-time system clock. The argument frame is an opaque, machine-dependent structure that encapsulates the previous machine state. The hardclock() performs different tasks such as: o Run the current process's virtual and profile time (decrease the corresponding timers, if they are activated, and generate SIGVTALRM or SIGPROF, respectively). o Increment the time-of-day, taking care of any ntpd(8) or adjtime(2) induced changes and leap seconds, as well as any necessary com- pensations to keep in sync with PPS signals or external clocks, if support for this is in the kernel (see options(4)). o Schedule softclock interrupts if any callouts should be triggered (see callout(9)). SEE ALSO
adjtime(2), ntp_adjtime(2), signal(7), ntpd(8), callout(9), hz(9) BSD
March 25, 2010 BSD

Check Out this Related Man Page

HZ(9)							   BSD Kernel Developer's Manual						     HZ(9)

NAME
hz, tick, tickadj, stathz, profhz -- system time model SYNOPSIS
#include <sys/kernel.h> extern int hz; extern int tick; extern int tickadj; extern int stathz; extern int profhz; DESCRIPTION
The essential clock handling routines in NetBSD are written to operate with two timers that run independently of each other. The main clock, running hz times per second, is used to keep track of real time. In another words, hz specifies the number of times the hardclock(9) timer ticks per second. Normally hardclock(9) increments time by tick each time it is called. If the system clock has drifted, adjtime(2) may be used to skew this increment based on the rate of tickadj. The second timer is used to gather timing statistics. It also handles kernel and user profiling. If the second timer is programmable, it is randomized to avoid aliasing between the two clocks. The mean frequency of the second timer is stathz. If a separate clock is not avail- able, stathz is set to hz. If profiling is enabled, the clock normally used to drive stathz may be run at a higher rate profhz, which is required to be a multiple of stathz. This will give higher resolution profiling information. These system variables are also available as struct clockinfo from sysctl(3) and kern.clockrate from sysctl(8). The hz is hardware-depen- dent; it can be overridden (if the machine dependent code supports this) by defining HZ in the kernel configuration file (see options(4)). Only override the default value if you really know what you are doing. SEE ALSO
adjtime(2), callout(9), hardclock(9), microtime(9), time_second(9) BSD
March 25, 2010 BSD
Man Page

4 More Discussions You Might Find Interesting

1. AIX

ntpd version

How to check the ntpd version of AIX 5.3 ? (3 Replies)
Discussion started by: alanlkw
3 Replies

2. Shell Programming and Scripting

Modifying the ntpd deamon script

I need to replace the line daemon ntpd $OPTIONS in the following script with daemon ntpd $OPTIONS 2>&1 > /var/log/ntpd.log & what will happen? The idea of replacing is to capture the output on the console into ntpd.log file. Will this work? ... (1 Reply)
Discussion started by: naive1977
1 Replies

3. Solaris

How to use "ntpd"

Hi All, How to synchronize two servers in time using ntpd command ? Plz tell me how to use it with some examples. Also mention which files are include in that process with proper path. Plz specify alternative commands for SunOS. Thanks in advance, VJ@UNIX :) (2 Replies)
Discussion started by: vikas898
2 Replies

4. Red Hat

NTPD service restart and time synch

I am using ntpd service to sync our RHEL 5.9 system to synch with GPS clock. When I change the RHEL system time more than 7 seconds than the present system time (through "Datetime" command), ntpd service does not adjust the system time to the present GPS time.But if the time is with in 7 seconds,... (6 Replies)
Discussion started by: Anjan Ganguly
6 Replies