NetBSD 6.1.5 - man page for shutdownhook_establish (netbsd section 9)
|Linux & Unix Commands - Search Man Pages
SHUTDOWNHOOK_ESTABLISH(9) BSD Kernel Developer's Manual SHUTDOWNHOOK_ESTABLISH(9)
shutdownhook_establish, shutdownhook_disestablish -- add or remove a shutdown hook
shutdownhook_establish(void (*fn)(void *), void *arg);
The shutdownhook_establish API is deprecated.
The shutdownhook_establish() function adds fn to the list of hooks invoked by
doshutdownhooks(9) at shutdown. When invoked, the hook function fn will be passed arg as
its only argument.
The shutdownhook_disestablish() function removes the hook described by the opaque pointer
cookie from the list of hooks to be invoked at shutdown. If cookie is invalid, the result
of shutdownhook_disestablish() is undefined.
Shutdown hooks should be used to perform one-time activities that must happen immediately
before the kernel exits. Because of the environment in which they are run, shutdown hooks
cannot rely on many system services (including file systems, and timeouts and other inter-
rupt-driven services), or even basic system integrity (because the system could be rebooting
after a crash).
If successful, shutdownhook_establish() returns an opaque pointer describing the newly-
established shutdown hook. Otherwise, it returns NULL.
It may be appropriate to use a shutdown hook to disable a device that does direct memory
access, so that the device will not try to access memory while the system is rebooting.
It may be appropriate to use a shutdown hook to inform watchdog timer hardware that the
operating system is no longer running.
The names are clumsy, at best.
BSD May 14, 2009 BSD
All times are GMT -4. The time now is 09:42 PM.