HZ(9) BSD Kernel Developer's Manual HZ(9)
hz, tick, tickadj, stathz, profhz -- system time model
extern int hz;
extern int tick;
extern int tickadj;
extern int stathz;
extern int profhz;
The essential clock handling routines in NetBSD are written to operate with two timers that
run independently of each other. The main clock, running hz times per second, is used to
keep track of real time.
In another words, hz specifies the number of times the hardclock(9) timer ticks per second.
Normally hardclock(9) increments time by tick each time it is called. If the system clock
has drifted, adjtime(2) may be used to skew this increment based on the rate of tickadj.
The second timer is used to gather timing statistics. It also handles kernel and user pro-
filing. If the second timer is programmable, it is randomized to avoid aliasing between the
two clocks. The mean frequency of the second timer is stathz. If a separate clock is not
available, stathz is set to hz.
If profiling is enabled, the clock normally used to drive stathz may be run at a higher rate
profhz, which is required to be a multiple of stathz. This will give higher resolution pro-
These system variables are also available as struct clockinfo from sysctl(3) and
kern.clockrate from sysctl(8). The hz is hardware-dependent; it can be overridden (if the
machine dependent code supports this) by defining HZ in the kernel configuration file (see
options(4)). Only override the default value if you really know what you are doing.
adjtime(2), callout(9), hardclock(9), microtime(9), time_second(9)
BSD March 25, 2010 BSD