NetBSD 6.1.5 - man page for lwp_cache_creds (netbsd section 9)
|Linux & Unix Commands - Search Man Pages
LWP_CACHE_CREDS(9) BSD Kernel Developer's Manual LWP_CACHE_CREDS(9)
LWP_CACHE_CREDS -- synchronize LWP credential with process credential
LWP_CACHE_CREDS(lwp_t *l, struct proc *p);
LWP_CACHE_CREDS() updates the LWP's cached credential to match with the process' credential
if the latter has been changed after the last synchronization.
Each LWPs have its cached credential so that it can be used without worrying about potential
of other LWP changing the process' credential. kauth_cred_get() returns the cached creden-
LWP_CACHE_CREDS() is called by MD entry code for system call and various traps. LWPs which
can live in kernel for long period should call LWP_CACHE_CREDS() by itsself to refresh its
LWP_CACHE_CREDS() takes the following arguments.
l The calling lwp.
p The process which the lwp l belongs to.
LWP_CACHE_CREDS() might be implemented as a macro.
BSD December 9, 2007 BSD
All times are GMT -4. The time now is 09:40 PM.