|Linux & Unix Commands - Search Man Pages
KPREEMPT(9) BSD Kernel Developer's Manual KPREEMPT(9)
kpreempt -- control kernel preemption
These functions are used to control kernel preemption of the calling LWP.
On architectures where kernel preemption is not supported natively, these functions may
still be used.
It should be noted that kernel preemption is also disabled when holding the interrupt prior-
ity level above IPL_NONE, e.g. using spl(9) or spinning mutex(9) calls or holding ker-
nel_lock (indicating that the code is not MT safe).
kpreempt_disable() disables kernel preemption of the calling LWP. Note that disabling ker-
nel preemption can prevent LWPs with higher priorities from running.
kpreempt_enable() enables kernel preemption of the calling LWP, which was previously dis-
abled by kpreempt_disable().
kpreempt_disable() and kpreempt_enable() can be nested.
kpreempt_disabled() returns true if preemption of the calling LWP is disabled. It is only
for diagnostic purpose.
intro(9), mutex(9), spl(9)
BSD February 16, 2010 BSD
All times are GMT -4. The time now is 09:24 PM.