MSTOHZ(9) BSD Kernel Developer's Manual MSTOHZ(9)NAME
mstohz, hztoms -- convert between milliseconds and system clock ticks
The mstohz() macro can be used to convert time in milliseconds to system clock ticks, as used by the callout(9) facility, in an integer-over-
flow safe way. Conversely, hztoms() converts system clock ticks to milliseconds.
These macros are defined in the <sys/param.h> header. Individual ports can have a processor-specific, more efficient version implemented in
their <machine/param.h> header as a define.
The return value is either the number of clock ticks or milliseconds for the specified value.
SEE ALSO param(3), callout(9), tvtohz(9)BUGS
Neither mstohz() nor hztoms() make use of expensive 64-bit integer arithmetic. The result from mstohz() will be rounded down to one second
if the parameter is larger than 131072 milliseconds.
BSD October 20, 2011 BSD
Check Out this Related Man Page
timeout - General: Initializes a callout queue element
int (*function) (),
register int time );
Specifies a pointer to the routine to be called. Specifies a single argument to be passed to the called routine. Specifies the amount of
time to delay before calling the specified routine. You express time as time (in seconds) * hz.
The timeout routine initializes a callout queue element to make it easy to execute the specified routine at the time specified in the time
argument. You often use callout routines for infrequent polling or error handling. The routine you specify will be called on the interrupt
stack (not in processor context) as dispatched from the softclock routine.
The global variable hz contains the number of clock ticks per second. This variable is a second's worth of clock ticks.
Thus, if you wanted a 4-minute timeout, you would pass 4 * 60 * hz as the third argument to the timeout routine as follows:
/* A 4-minute timeout */
timeout(lptout, (caddr_t)dev, 4 * 60 * hz);
The granularity of the time delay is dependent on the hardware. For example, the granularity of some Alpha CPUs is 1024 clock ticks per
second. Other Alpha CPUs have a granularity of 1200 clock ticks per second. Still other Alpha CPUs exhibit a granularity of 128 clock
ticks per second. Because the granularity of the time delay is dependent on the hardware, the operating system provides the hz and lbolt
global variables. Use the hz global variable to determine the number of clock ticks per second for a specific Alpha CPU. Use the lbolt
global variable as a periodic wakeup mechanism.
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)