Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

edid(9) [netbsd man page]

EDID(9) 						   BSD Kernel Developer's Manual						   EDID(9)

NAME
edid -- VESA Extended Display Identification Data SYNOPSIS
#include <dev/videomode/edidvar.h> #include <dev/videomode/edidreg.h> int edid_is_valid(uint8_t *data); int edid_parse(uint8_t *data, struct edid_info *info); void edid_print(struct edid_info *info); DESCRIPTION
These functions provide support parsing the Extended Display Identification Data which describes a display device such as a monitor or flat panel display. The edid_is_valid() function simply tests if the EDID block in data contains valid data. This test includes a verification of the checksum, and that valid vendor and product idenfication data is present. The data block contain at least 128 bytes. The edid_parse() function parses the supplied data block (which again, must be at least 128 bytes), writing the relevant data into the struc- ture pointed to by info. The edid_print() function prints the data in the given info structure to the console device. RETURN VALUES
The edid_is_valid() function returns 0 if the data block is valid, and EINVAL otherwise. The edid_parse() function returns zero if the data was successfully parsed, and non-zero otherwise. CODE REFERENCES
The EDID subsystem is implemented within the file sys/dev/videomode/edid.c. The EDID subsystem also makes use of VESA Generalized Timing Formula located located in sys/dev/videomode/vesagtf.c and the generic videomode database located in sys/dev/videomode/videomode.c. EXAMPLES
The following code uses these functions to retrieve and print information about a monitor: struct edid_info info; i2c_tag_t tag; char buffer[128]; ... /* initialize i2c tag... */ ... if ((ddc_read_edid(tag, buffer, 128) == 0) && (edid_parse(buffer, &info) == 0)) edid_print(info); ... SEE ALSO
ddc(9), iic(9) HISTORY
These routines were added in NetBSD 4.0. AUTHORS
Garrett D'Amore <gdamore@NetBSD.org> BSD
May 11, 2006 BSD

Check Out this Related Man Page

IIC(4)							   BSD Kernel Interfaces Manual 						    IIC(4)

NAME
iic -- I2C generic I/O device driver SYNOPSIS
device iic #include <dev/iicbus/iic.h> DESCRIPTION
The iic device driver provides generic I/O to any iicbus(4) instance. In order to control I2C devices, use /dev/iic? with the following ioctls: I2CSTART (struct iiccmd) Sends the start condition to the slave specified by the slave element to the bus. All other elements are ignored. I2CRPTSTART (struct iiccmd) Sends the repeated start condition to the slave specified by the slave element to the bus. All other elements are ignored. I2CSTOP No argument is passed. Sends the stop condition to the bus. This terminates the current transaction. I2CRSTCARD (struct iiccmd) Resets the bus. The argument is completely ignored. I2CWRITE (struct iiccmd) Writes data to the iicbus(4). The bus should already be started. The slave element is ignored. The count ele- ment is the number of bytes to write. The last element is a boolean flag. It is non-zero when additional write commands will follow. The buf element is a pointer to the data to write to the bus. I2CREAD (struct iiccmd) Reads data from the iicbus(4). The bus should already be started. The slave element is ignored. The count element is the number of bytes to write. The last element is a boolean flag. It is non-zero when additional write commands will follow. The buf element is a pointer to where to store the data read from the bus. Short reads on the bus produce unde- fined results. I2CRDWR (struct iic_rdwr_data) Generic read/write interface. Allows for an arbitrary number of commands to be sent to an arbitrary num- ber of devices on the bus. A read transfer is specified if IIC_M_RD is set in flags. Otherwise the transfer is a write trans- fer. The slave element specifies the 7-bit address for the transfer. The len element is the length of the data. The buf ele- ment is a buffer for that data. This ioctl is intended to be Linux compatible. The following data structures are defined in <dev/iicbus/iic.h> and referenced above: struct iiccmd { u_char slave; int count; int last; char *buf; }; /* Designed to be compatible with linux's struct i2c_msg */ struct iic_msg { uint16_t slave; uint16_t flags; #define IIC_M_RD 0x0001 /* read vs write */ uint16_t len; /* msg legnth */ uint8_t * buf; }; struct iic_rdwr_data { struct iic_msg *msgs; uint32_t nmsgs; }; It is also possible to use read/write routines, then I2C start/stop handshake is managed by the iicbus(4) system. However, the address used for the read/write routines is the one passed to last I2CSTART ioctl(2) to this device. SEE ALSO
ioctl(2), read(2), write(2), iicbus(4) HISTORY
The iic manual page first appeared in FreeBSD 3.0. AUTHORS
This manual page was written by Nicolas Souchu and M. Warner Losh. BUGS
Only the I2CRDWR ioctl(2) is thread safe. All other interfaces suffer from some kind of race. BSD
September 6, 2006 BSD
Man Page