DOSHUTDOWNHOOKS(9) BSD Kernel Developer's Manual DOSHUTDOWNHOOKS(9)NAME
doshutdownhooks -- run all shutdown hooks
SYNOPSIS
void
doshutdownhooks(void);
DESCRIPTION
The doshutdownhooks routine is deprecated. Use pmf_system_shutdown(9) instead.
The doshutdownhooks() function invokes all shutdown hooks established using the shutdownhook_establish(9) function. Shutdown hooks are
called in reverse order, i.e., the shutdown hook established last will be called first.
This function is called from cpu_reboot() with interrupts turned off. It is called immediately before the system is halted or rebooted,
after file systems have been unmounted, after the clock has been updated, and after a system dump has been done (if necessary).
SEE ALSO cpu_reboot(9), shutdownhook_establish(9)BSD February 11, 2010 BSD
Check Out this Related Man Page
POWERHOOK_ESTABLISH(9) BSD Kernel Developer's Manual POWERHOOK_ESTABLISH(9)NAME
powerhook_establish, powerhook_disestablish -- add or remove a power change hook
SYNOPSIS
void *
powerhook_establish(const char *name, void (*fn)(int why, void *a), void *arg);
void
powerhook_disestablish(void *cookie);
DESCRIPTION
The powerhook_establish API is deprecated.
The powerhook_establish() function adds fn of the list of hooks invoked by dopowerhooks(9) at power change. When invoked, the hook function
fn will be passed the new power state as the first argument and arg as its second argument.
The powerhook_disestablish() function removes the hook described by the opaque pointer cookie from the list of hooks to be invoked at power
change. If cookie is invalid, the result of powerhook_disestablish() is undefined.
Power hooks should be used to perform activities that must happen when the power situation to the computer changes. Because of the environ-
ment in which they are run, power hooks cannot rely on many system services (including file systems, and timeouts and other interrupt-driven
services). The power hooks are typically executed from an interrupt context.
The different reasons for calling the power hooks are: suspend, standby, and resume. The reason is reflected in the why argument and the
values PWR_SOFTSUSPEND, PWR_SUSPEND, PWR_SOFTSTANDBY, PWR_STANDBY, PWR_SOFTRESUME, and PWR_RESUME. It calls with PWR_SOFTxxx in the normal
priority level while the other callings are protected with splhigh(9). At suspend the system is going to lose (almost) all power, standby
retains some power (e.g., minimal power to USB devices), and at resume power is back to normal.
RETURN VALUES
If successful, powerhook_establish() returns an opaque pointer describing the newly-established power hook. Otherwise, it returns NULL.
SEE ALSO dopowerhooks(9)BSD May 14, 2009 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)