Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

delay(9) [netbsd man page]

DELAY(9)						   BSD Kernel Developer's Manual						  DELAY(9)

NAME
delay, DELAY -- microsecond delay SYNOPSIS
#include <machine/param.h> void delay(unsigned int us); void DELAY(unsigned int us); DESCRIPTION
Wait approximately us microseconds. The delay is implemented as a machine loop, preventing events other than interrupt handlers for unmasked interrupts to run. DELAY() is reen- trant (doesn't modify any global kernel or machine state) and is safe to use in interrupt or process context. For long delays, condition variables should be considered, however they can only be used from process context and their resolution is limited by the system clock frequency. SEE ALSO
condvar(9), hz(9), kpause(9) BSD
July 20, 2011 BSD

Check Out this Related Man Page

DELAY.4TH(8)						    BSD System Manager's Manual 					      DELAY.4TH(8)

NAME
delay.4th -- FreeBSD debugging boot module DESCRIPTION
The file that goes by the name of delay.4th is a set of commands designed to add debugging capabilities to loader(8). The commands of delay.4th by themselves are not enough for most uses. Please refer to the examples below for the most common situations, and to loader(8) for additional commands. Before using any of the commands provided in delay.4th, it must be included through the command: include delay.4th This line is present in /boot/beastie.4th file, so it is not needed (and should not be re-issued) in a normal setup. The commands provided by it are: delay_execute Executes the [string] procedure stored in the delay_command environment variable after loader_delay seconds. If the optional delay_showdots environment variable is set, a continuous series of dots is printed. During the duration, the user can either press Ctrl-C (or Esc) to abort or ENTER to proceed immediately. The environment variables that effect its behavior are: delay_command The command to be executed by delay_execute. loader_delay The duration (in seconds) to delay before executing delay_command. delay_showdots If set, will cause delay_execute to print a continuous series of dots during the delay duration. FILES
/boot/loader The loader(8). /boot/delay.4th delay.4th itself. /boot/loader.rc loader(8) bootstrapping script. EXAMPLES
Introducing a 5-second delay before including another file from /boot/loader.rc: include /boot/delay.4th set delay_command="include /boot/other.4th" set delay_showdots set loader_delay=5 delay_execute SEE ALSO
loader.conf(5), beastie.4th(8), loader(8), loader.4th(8) HISTORY
The delay.4th set of commands first appeared in FreeBSD 9.0. AUTHORS
The delay.4th set of commands was written by Devin Teske <dteske@FreeBSD.org>. BSD
May 18, 2011 BSD
Man Page

15 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

how to introduce delay in the script??(urgent)

Hi all, i would like to know how to introduce a delay in the execution of a cmd? am trying to copy a file which is about 650 mb and then perform some actions on it.. however since its huge i would like to introduce a delay in exection until the process is over i dont want it to proceed to... (10 Replies)
Discussion started by: wrapster
10 Replies

2. Shell Programming and Scripting

Grep causing long delay (batching) whilst piping

Hi all. I have a problem at work which I have managed to break down into a simple test scenario: I have written a monitoring script that outputs every second the status of various processes, but for now, lets just print the date input.sh: while true do date sleep 1 done This... (9 Replies)
Discussion started by: spudtheimpaler
9 Replies

3. AIX

Printer delay before final form feed

Hi, I am new to printing with Unix (AIX on HP). I am printing from a COBOL program. On our test system the page prints and does a Form Feed to the next page. This is good. When I release the program to our customer it prints the page but waits 5 or more seconds before doing a page... (11 Replies)
Discussion started by: habler
11 Replies

4. Linux

Delay gnome shutdown/restart

Hi to all. My first message here, but i following you via twitter feed from many time... The question: I need to delay 5-10 seconds the shutdown command executed when the user click on the power off/reboot in their session or at login screen. I need that because i have in the background a... (18 Replies)
Discussion started by: mendez
18 Replies

5. AIX

Read input data within a specified period of time

Hi All, I am working on a script which requires an input from user within one 1 min. So if the user gives the required input within 1 min., it will execute on the basis of input provided by the user.Other wise it will execute on a default value(hard coded inside the script). Now, I am... (19 Replies)
Discussion started by: rajsharma
19 Replies

6. Shell Programming and Scripting

How do I do a short delay (milliseconds) in a shell script?

I need to put a small delay into a shell script. I'm looking for something smaller than "sleep" - a second is way too long. I want to sleep something like 10 milliseconds. I've tried "usleep" and "nanosleep", but the script doesn't recognize them. I'm using the bash shell but I'm willing to... (9 Replies)
Discussion started by: harmlesscat
9 Replies

7. Red Hat

Login to server takes time

When I am trying to login to a server using Putty ssh from my windows xp machine it is taking too much time for login. My server name is http2 and when I enter this address into putty I immediately get login as: screen, but after I put my username root and enter the cursor moves downwards... (14 Replies)
Discussion started by: abhilashkrishn
14 Replies

8. SCO

Openserver 5.0.5 - logon delay

We have an OpenServer 5.0.5 system that has worked forever, but I'm hearing complaints of logon delays for users now. Normally they would telnet in and the logon screen would pop up, but now it sometimes takes a minute or more, and the user must hit the enter key to get it to appear. Everything... (11 Replies)
Discussion started by: citygov
11 Replies

9. Emergency UNIX and Linux Support

Time delay problem in asking password

Hi All, I have solaris-11 global and multiple non-global zones running, which all are on same network. They are not in NIS. When we open putty session and give user-name, it takes long time in asking password (around 40-50 seconds) on Global zone. While on non-global zones, it is working... (9 Replies)
Discussion started by: solaris_1977
9 Replies

10. Solaris

Solaris 9 Zone : Date command in crontab shows delayed(One Hour) output

SOLARIS 9 Zone : date command in crontab shows delayed(One Hour) output Hi folks, the date command shows the correct date and time, How ever, if the date command executed through crontab in any form of scrip the output shows as one hour delayed, similar to date -u.. Can some one help in... (12 Replies)
Discussion started by: judi
12 Replies

11. Solaris

Solaris 9 - SSH 40 Second Delay

I'm having an issue with SSH on a server that hasn't had any configuration changes made on it in a long time. I SSH to the server and it hangs at "debug1: SSH2_MSG_KEXINIT sent" for exactly 40 seconds then connects fine after that pause. Everything I have found points to DNS, but I use host files... (19 Replies)
Discussion started by: kingdbag
19 Replies

12. UNIX for Dummies Questions & Answers

Very big delay (about 300 sec) before autentification

Dear all, I got a problem and have no idea how to solve it. I was searching in the forum and google it and have found similar problem but provided solution doesn't help me. I have Solaris 11: Oracle Solaris 11 11/11 X86 Copyright (c) 1983, 2011, Oracle and/or its affiliates. ... (13 Replies)
Discussion started by: nypreH
13 Replies

13. Shell Programming and Scripting

BASH Execution Delay / Speedup

I have a BASH script that runs a continuous loop, reading a line from a file, and then spawning a background process to use it. I've placed "date" commands inside it to see where it's slowing down, and everything inside -- including reading the line from the file -- is fast, but the loop bogs... (34 Replies)
Discussion started by: gmark99
34 Replies

14. Solaris

SSH and telnet long delay to recieve prompt.

Hi guys. You'd have to excuse me a bit, as I'm a noob. I really try to avoid asking questions and do research for whatever linux issues that may arise. I am experiencing a long wait for the shell to come up when I ssh or telnet into a Sunos 5.10 environment. It takes 70 seconds to give me... (12 Replies)
Discussion started by: gpenco
12 Replies

15. UNIX and Linux Applications

Sendmail delay: 3 mins 11 secs... Every time.

Hi all, I would like some help with a sendmail problem: We have a new system comprising of 4 T7-1 servers, each hosting 5 LDOMs, all domains running Solaris 11.3 All emails sent from every one of these domains (including the control domains) sit in the queue for 3 mins 11 secs (sometime 3m 12s,... (11 Replies)
Discussion started by: Mysturji
11 Replies