netbsd man page for delay

Query: delay

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DELAY(9)						   BSD Kernel Developer's Manual						  DELAY(9)

NAME
delay, DELAY -- microsecond delay
SYNOPSIS
#include <machine/param.h> void delay(unsigned int us); void DELAY(unsigned int us);
DESCRIPTION
Wait approximately us microseconds. The delay is implemented as a machine loop, preventing events other than interrupt handlers for unmasked interrupts to run. DELAY() is reen- trant (doesn't modify any global kernel or machine state) and is safe to use in interrupt or process context. For long delays, condition variables should be considered, however they can only be used from process context and their resolution is limited by the system clock frequency.
SEE ALSO
condvar(9), hz(9), kpause(9)
BSD
July 20, 2011 BSD
Related Man Pages
drv_usecwait(9f) - opensolaris
drv_usecwait(9f) - centos
delay.4th(8) - freebsd
drv_usecwait(9f) - hpux
drv_usecwait(9f) - debian
Similar Topics in the Unix Linux Community
how to introduce delay in the script??(urgent)
Printer delay before final form feed
How do I do a short delay (milliseconds) in a shell script?
Solaris 9 Zone : Date command in crontab shows delayed(One Hour) output
Very big delay (about 300 sec) before autentification