YPPUSH(8) BSD System Manager's Manual YPPUSH(8)NAME
yppush -- force distribution of NIS map
yppush [-v] [-d domainname] [-h hostname] mapname
yppush is used to distribute a NIS map from a master server to any slave server in the domain. The list of servers of domainname are fetched
from the NIS map ypservers.
The options are as follows:
-d domainname NIS domain to use instead of the default domain.
-h hostname Distribute map only to one host and not to the hosts in the ypserver map.
-v Verbose. Announce what the program is doing.
SEE ALSO domainname(1), nis(8), ypserv(8)AUTHORS
Charles D. Cranor
BSD February 26, 2005 BSD
Check Out this Related Man Page
yppush(8) System Manager's Manual yppush(8)NAME
yppush - force propagation of a changed Network Information Service (NIS) map
yppush [-d domain] [-v] mapname
Specify a domain. Verbose. This causes messages to be printed when each server is called, and for each response. Without this option, only
error messages are printed.
The yppush command copies a new version of a Network Information Service (NIS) map from the master NIS server to the slave NIS servers. It
is normally run only on the master NIS server by the make utility accessing the /var/yp/Makefile after the master NIS databases have been
changed. When invoked, yppush first constructs a list of NIS server hosts by reading the NIS map ypservers within the domain. Keys within
the map ypservers are the ASCII names of the machines on which the NIS servers run.
A transfer map request is sent to the NIS server at each host, along with the information needed by the transfer agent (the program which
actually moves the map) to call back the yppush command. When the attempt has completed (successfully or not), and the transfer agent has
sent yppush a status message, the results can be printed to stdout. Messages are also printed when a transfer is not possible, for
instance when the request message is undeliverable, or when the timeout period on responses has expired.
Refer to ypfiles(4) and ypserv(8) for an overview of NIS.
In the current implementation (version 2 NIS protocol), the transfer agent is ypxfr, which is started by the ypserv program. If yppush
detects that it is speaking to a version 1 NIS protocol server, it uses the older protocol, sending a version 1 YPPROC_GET request and
issues a message to that effect. Unfortunately, there is no way of knowing if or when the map transfer was performed for version 1 servers.
The yppush command prints a message saying that an old-style message has been sent. The system administrator should later check to see that
the transfer has actually taken place.
Map xxx no such map in server's domain -- using ypservers
This is an informational message that indicates that the yppush command will push the maps to all servers listed in the ypservers map.
FILES SEE ALSO
Commands: ypserv(8), ypxfr(8)