USERINFO(8) BSD System Manager's Manual USERINFO(8)NAME
userinfo -- displays user information
userinfo [-e] user
The userinfo utility retrieves the user information from the system. The userinfo utility is only available if built with EXTENSIONS. See
user(8) for more information.
The following command line option is recognised:
-e Return 0 if the user exists, and non-zero if the user does not exist, on the system. No information is displayed. This form of the
command is useful for scripts which need to check whether a particular user name or uid is already in use on the system.
The user argument may either be a user's name, or a uid.
The userinfo utility exits 0 on success, and >0 if an error occurs.
SEE ALSO passwd(5), group(8), user(8), useradd(8), userdel(8)HISTORY
The userinfo utility first appeared in NetBSD 1.5. It is based on the addnerd package by the same author.
The userinfo utility was written by Alistair G. Crooks <agc@NetBSD.org>.
BSD November 16, 2005 BSD
Check Out this Related Man Page
GROUPADD(8) BSD System Manager's Manual GROUPADD(8)NAME
groupadd -- add a group to the system
groupadd [-ov] [-g gid] [-r lowgid..highgid] group
The groupadd utility adds a group to the system. See group(8) for more information about EXTENSIONS. The options are as follows:
-g gid Give the numeric group identifier to be used for the new group.
-o Allow the new group to have a gid which is already in use for another group.
Set the low and high bounds of a gid range for new groups. A new group can only be created if there are gids which can be assigned
inside the range. This option is included if built with EXTENSIONS.
-v Enable verbose mode - explain the commands as they are executed. This option is included if built with EXTENSIONS.
The groupadd utility exits 0 on success, and >0 if an error occurs.
SEE ALSO group(5), group(8), user(8)HISTORY
The groupadd utility first appeared in NetBSD 1.5. It is based on the addnerd package by the same author.
The groupadd utility was written by Alistair G. Crooks <agc@NetBSD.org>.
BSD November 7, 2005 BSD
I want to set a size limitation for some user in the system, for an example, each user only have 5MB free space in the system. The user cannot user more than 5 MB space.
Is it possible to do this? Thanks! (1 Reply)
Is there any utility or command to read a .gz file without GUNZIPing it?
Why I need this because of the huge size of the file. I am looking for something like zcat. Any help is aprreciated.
Thanks in Advance..
rin... (1 Reply)
I have written a program using shell scripting. When you run the file it will asks you to enter the user name, if the user exists it says " user exists " if not it will displays like " user doesnt exist" and then asks you like " do you want to add user with options Yes or No " if you say... (1 Reply)
The lines in bold check the value of a user input, if it is not one of the expected genes (GJB2, MECP2, PHOX2B), the user is shown a list of formats to use and the variant is entered. It is then supposed to printf that entered variant? Thank you :).
printf... (2 Replies)