Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

tprof(8) [netbsd man page]

TPROF(8)						    BSD System Manager's Manual 						  TPROF(8)

NAME
tprof -- record tprof profiling samples SYNOPSIS
tprof [-c] [-o file] command ... DESCRIPTION
The tprof is a sampling based profiler. tprof utility makes the kernel driver start profiling, executes the specified command, keeps recording samples from the kernel driver until the command finishes, and reports statistics to the standard error. The tprof pseudo driver and a suitable backend should be loaded beforehand. The tprof utility accepts the following options. -o file Write the collected samples to the file named file. The default is ``tprof.out''. -c Write the collected samples to the standard output. Note that the output is a binary stream. EXAMPLES
The following command profiles the system during 1 second and shows the top-10 kernel functions which likely consumed CPU cycles. tprof -c sleep 1 2>/dev/null | tpfmt -skCLP | head -10 DIAGNOSTICS
The tprof utility reports the following statistics about the activities of the tprof pseudo driver. sample The number of samples collected and prepared for userland consumption. overflow The number of samples dropped because the per-CPU buffer was full. buf The number of buffers successfully prepared for userland consumption. emptybuf The number of buffers which have been dropped because they were empty. dropbuf The number of buffers dropped because the number of buffers kept in the kernel exceeds the limit. dropbuf_samples The number of samples dropped because the buffers containing the samples were dropped. SEE ALSO
tpfmt(1), tprof(4) AUTHORS
The tprof utility is written by YAMAMOTO Takashi. CAVEATS
The contents and representation of recorded samples are undocumented and will likely be changed for future releases of NetBSD in an incompat- ible way. BSD
November 26, 2011 BSD

Check Out this Related Man Page

PROFIL(2)						      BSD System Calls Manual							 PROFIL(2)

NAME
profil -- control process profiling LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <unistd.h> int profil(char *samples, size_t size, vm_offset_t offset, int scale); DESCRIPTION
The profil() system call enables or disables program counter profiling of the current process. If profiling is enabled, then at every pro- filing clock tick, the kernel updates an appropriate count in the samples buffer. The frequency of the profiling clock is recorded in the header in the profiling output file. The buffer samples contains size bytes and is divided into a series of 16-bit bins. Each bin counts the number of times the program counter was in a particular address range in the process when a profiling clock tick occurred while profiling was enabled. For a given program counter address, the number of the corresponding bin is given by the relation: [(pc - offset) / 2] * scale / 65536 The offset argument is the lowest address at which the kernel takes program counter samples. The scale argument ranges from 1 to 65536 and can be used to change the span of the bins. A scale of 65536 maps each bin to 2 bytes of address range; a scale of 32768 gives 4 bytes, 16384 gives 8 bytes and so on. Intermediate values provide approximate intermediate ranges. A scale value of 0 disables profiling. RETURN VALUES
The profil() function returns the value 0 if successful; otherwise the value -1 is returned and the global variable errno is set to indicate the error. FILES
/usr/lib/gcrt0.o profiling C run-time startup file gmon.out conventional name for profiling output file ERRORS
The following error may be reported: [EFAULT] The buffer samples contains an invalid address. SEE ALSO
gprof(1) HISTORY
The profil() function appeared in Version 7 AT&T UNIX. BUGS
This routine should be named profile(). The samples argument should really be a vector of type unsigned short. The format of the gmon.out file is undocumented. BSD
June 4, 1993 BSD
Man Page