|Linux & Unix Commands - Search Man Pages
RESIZE_LFS(8) BSD System Manager's Manual RESIZE_LFS(8)
resize_lfs -- resize a mounted log-structured filesystem
resize_lfs [-v] [-s new-size] mounted-file-system
resize_lfs grows or shrinks a mounted log-structured filesystem to the specified size.
mounted-file-system is the name of the filesystem to be resized, and new-size is the desired
new filesystem size, in sectors. If new-size is not specified, resize_lfs will default to
the current size of the partition containing the filesystem in question.
When growing, the partition must be large enough to contain a filesystem of the specified
size; when shrinking, resize_lfs must first ``clean'' the segments that will be invalid when
the filesystem is shrunk. If this cleaning process results in these segments becoming
redirtied, this indicates that the given new size is not large enough to contain the exist-
ing filesystem data, and resize_lfs will return an error.
To resize the file system mounted at /home to 32576 sectors:
resize_lfs -s 32576 /home
fsck_lfs(8), lfs_cleanerd(8), newfs_lfs(8)
The resize_lfs command first appeared in NetBSD 3.0.
Konrad Schroder <perseant@NetBSD.org>
resize_lfs should be able to resize an unmounted filesystem as well.
BSD September 4, 2006 BSD
All times are GMT -4. The time now is 02:14 PM.