RESIZE_LFS(8) BSD System Manager's Manual RESIZE_LFS(8)NAME
resize_lfs -- resize a mounted log-structured filesystem
resize_lfs [-v] [-s new-size] mounted-file-system
resize_lfs grows or shrinks a mounted log-structured filesystem to the specified size. mounted-file-system is the name of the filesystem to
be resized, and new-size is the desired new filesystem size, in sectors. If new-size is not specified, resize_lfs will default to the cur-
rent size of the partition containing the filesystem in question.
When growing, the partition must be large enough to contain a filesystem of the specified size; when shrinking, resize_lfs must first
``clean'' the segments that will be invalid when the filesystem is shrunk. If this cleaning process results in these segments becoming
redirtied, this indicates that the given new size is not large enough to contain the existing filesystem data, and resize_lfs will return an
To resize the file system mounted at /home to 32576 sectors:
resize_lfs -s 32576 /home
SEE ALSO fsck_lfs(8), lfs_cleanerd(8), newfs_lfs(8)HISTORY
The resize_lfs command first appeared in NetBSD 3.0.
Konrad Schroder <perseant@NetBSD.org>
resize_lfs should be able to resize an unmounted filesystem as well.
BSD September 4, 2006 BSD
Check Out this Related Man Page
RESIZE2FS(8) System Manager's Manual RESIZE2FS(8)NAME
resize2fs - ext2/ext3/ext4 file system resizer
resize2fs [ -fFpPM ] [ -d debug-flags ] [ -S RAID-stride ] device [ size ]
The resize2fs program will resize ext2, ext3, or ext4 file systems. It can be used to enlarge or shrink an unmounted file system located
on device. If the filesystem is mounted, it can be used to expand the size of the mounted filesystem, assuming the kernel supports on-line
resizing. (As of this writing, the Linux 2.6 kernel supports on-line resize for filesystems mounted using ext3 only.).
The size parameter specifies the requested new size of the filesystem. If no units are specified, the units of the size parameter shall be
the filesystem blocksize of the filesystem. Optionally, the size parameter may be suffixed by one of the following the units designators:
's', 'K', 'M', or 'G', for 512 byte sectors, kilobytes, megabytes, or gigabytes, respectively. The size of the filesystem may never be
larger than the size of the partition. If size parameter is not specified, it will default to the size of the partition.
The resize2fs program does not manipulate the size of partitions. If you wish to enlarge a filesystem, you must make sure you can expand
the size of the underlying partition first. This can be done using fdisk(8) by deleting the partition and recreating it with a larger size
or using lvextend(8), if you're using the logical volume manager lvm(8). When recreating the partition, make sure you create it with the
same starting disk cylinder as before! Otherwise, the resize operation will certainly not work, and you may lose your entire filesystem.
After running fdisk(8), run resize2fs to resize the ext2 filesystem to use all of the space in the newly enlarged partition.
If you wish to shrink an ext2 partition, first use resize2fs to shrink the size of filesystem. Then you may use fdisk(8) to shrink the
size of the partition. When shrinking the size of the partition, make sure you do not make it smaller than the new size of the ext2
OPTIONS -d debug-flags
Turns on various resize2fs debugging features, if they have been compiled into the binary. debug-flags should be computed by adding
the numbers of the desired features from the following list:
2 - Debug block relocations
4 - Debug inode relocations
8 - Debug moving the inode table
-f Forces resize2fs to proceed with the filesystem resize operation, overriding some safety checks which resize2fs normally enforces.
-F Flush the filesystem device's buffer caches before beginning. Only really useful for doing resize2fs time trials.
-M Shrink the filesystem to the minimum size.
-p Prints out a percentage completion bars for each resize2fs operation, so that the user can keep track of what the program is doing.
-P Print the minimum size of the filesystem and exit.
The resize2fs program will heuristically determine the RAID stride that was specified when the filesystem was created. This option
allows the user to explicitly specify a RAID stride setting to be used by resize2fs instead.
The minimum size of the filesystem as estimated by resize2fs may be incorrect, especially for filesystems with 1k and 2k blocksizes.
resize2fs was written by Theodore Ts'o <email@example.com>.
Resize2fs is Copyright 1998 by Theodore Ts'o and PowerQuest, Inc. All rights reserved. As of April, 2000 Resize2fs may be redistributed
under the terms of the GPL.
SEE ALSO fdisk(8), e2fsck(8), mke2fs(8), lvm(8), lvextend(8)E2fsprogs version 1.41.11 March 2010 RESIZE2FS(8)