DUMP_LFS(8) BSD System Manager's Manual DUMP_LFS(8)
dump_lfs, rdump_lfs -- filesystem backup
dump_lfs [-0123456789aceFnStuX] [-B records] [-b blocksize] [-d density] [-f file] [-h level] [-k read-blocksize] [-L label] [-l timeout]
[-r cachesize] [-s feet] [-T date] [-x snap-backup] files-to-dump
dump_lfs [-W | -w]
(The 4.3BSD option syntax is implemented for backward compatibility, but is not documented here).
dump_lfs examines files on a file system and determines which files need to be backed up. These files are copied to the given disk, tape or
other storage medium for safe keeping (see the -f option below for doing remote backups). A dump that is larger than the output medium is
broken into multiple volumes. On most media the size is determined by writing until an end-of-media indication is returned. This can be
enforced by using the -a option.
On media that cannot reliably return an end-of-media indication (such as some cartridge tape drives) each volume is of a fixed size; the
actual size is determined by the tape size and density and/or block count options below. By default, the same output file name is used for
each volume after prompting the operator to change media.
files-to-dump is either a single file system, or a list of files and directories on a single file system to be backed up as a subset of the
file system. In the former case, files-to-dump may be the device of a file system, the path to a currently mounted file system, the path to
an unmounted file system listed in /etc/fstab, or, if -F is given, a file system image. In the latter case, certain restrictions are placed
on the backup: -u is ignored, the only dump level that is supported is -0, and all of the files must reside on the same file system.
The following options are supported by dump_lfs:
-0-9 Dump levels. A level 0, full backup, guarantees the entire file system is copied (but see also the -h option below). A level number
above 0, incremental backup, tells dump to copy all files new or modified since the last dump of a lower level. The default level is
-a ``auto-size''. Bypass all tape length considerations, and enforce writing until an end-of-media indication is returned. This fits
best for most modern tape drives. Use of this option is particularly recommended when appending to an existing tape, or using a tape
drive with hardware compression (where you can never be sure about the compression ratio).
The number of kilobytes per volume, rounded down to a multiple of the blocksize. This option overrides the calculation of tape size
based on length and density.
The number of kilobytes per dump record.
-c Modify the calculation of the default density and tape size to be more appropriate for cartridge tapes.
Set tape density to density. The default is 1600 Bits Per Inch (BPI).
-e Eject tape automatically if a tape change is required.
-F Indicates that files-to-dump is a file system image.
Write the backup to file; file may be a special device file like /dev/rst0 (a tape drive), /dev/rsd1c (a disk drive), an ordinary
file, or '-' (the standard output). Multiple file names may be given as a single argument separated by commas. Each file will be
used for one dump volume in the order listed; if the dump requires more volumes than the number of names given, the last file name
will used for all remaining volumes after prompting for media changes. If the name of the file is of the form "host:file", or
"user@host:file", dump_lfs writes to the named file on the remote host using rmt(8). Note that methods more secure than rsh(1) (such
as ssh(1)) can be used to invoke rmt(8) on the remote host, via the environment variable RCMD_CMD. See rcmd(3) for more details.
Honor the user "nodump" flag (UF_NODUMP) only for dumps at or above the given level. The default honor level is 1, so that incremen-
tal backups omit such files but full backups retain them.
The size in kilobyte of the read buffers, rounded up to a multiple of the file system block size. Default is 32k.
If a tape change is required, eject the tape and wait for the drive to be ready again. This is to be used with tape changers which
automatically load the next tape when the tape is ejected. If after the timeout (in seconds) the drive is not ready dump_lfs falls
back to the default behavior, and prompts the operator for the next tape.
The user-supplied text string label is placed into the dump header, where tools like restore(8) and file(1) can access it. Note that
this label is limited to be at most LBLSIZE (currently 16) characters, which must include the terminating '