NETGROUP_MKDB(8) BSD System Manager's Manual NETGROUP_MKDB(8)NAME
netgroup_mkdb -- generate the netgroup database
netgroup_mkdb [-o database] [file]
netgroup_mkdb creates a db(3) database for the specified file. If no file is specified, then /etc/netgroup is used. This database is
installed into /var/db/netgroup.db. The file must be in the correct format (see netgroup(5)).
The options are as follows:
Put the output databases in the named file.
The databases are used by the C library netgroup routines (see getnetgrent(3)).
netgroup_mkdb exits zero on success, non-zero on failure.
/var/db/netgroup.db The current netgroup database
/var/db/netgroup.db.tmp A temporary file
/etc/netgroup The current netgroup file
SEE ALSO db(3), getnetgrent(3), netgroup(5)BUGS
Because netgroup_mkdb guarantees not to install a partial destination file it must build a temporary file in the same file system and if suc-
cessful use rename(2) to install over the destination file.
If netgroup_mkdb fails it will leave the previous version of the destination file intact.
BSD May 20, 2007 BSD
Check Out this Related Man Page
REVNETGROUP(8) Reference Manual REVNETGROUP(8)NAME
revnetgroup - generate reverse netgroup data
Revnetgroup processes the standard input in netgroup(5) format into what is called reverse netgroup form. That is, where the original file
shows netgroup memberships in terms of which members reside in a particular group, the reverse netgroup format specifies what groups are
associated with a particular member. This information is used to generate the netgroup.byuser and netgroup.byhosts NIS maps. These reverse
netgroup maps are used to help speed up netgroup lookups, particularly for the innetgr library function.
The revnetgroup command prints its results on the standard output. It is usually called only by /var/yp/Makefile when rebuilding the NIS
The revnetgroup command supports the following options:
-u Generate netgroup.byuser output; only username information in the original netgroup file is processed.
-h Generate netgroup.byhost output; only hostname information in the original netgroup file is processed.
Note at least one of the both flags must be specified.
/var/yp/Makefile The Makefile to build the NIS databases
/etc/netgroup the default netgroup database file. This file is most often found only on the NIS master server
SEE ALSO getnetgrent(3), netgroup(5),
revnetgroup was written by Thorsten Kukuk <firstname.lastname@example.org>.
YP Server August 2001 REVNETGROUP(8)
I'd setup a nis server and 4 slaves. Update of passwd work's fine, but if i create a netgroup file the make all process hang by push the netgroup file.
I work with AIX 22.214.171.124 and Maintance Level 5.
Tank's for help (1 Reply)
We have netgroup in ldap in Sun java directory server, how can I add or remove a user to/from a netgroup via command line without using ldif file? I need to put this into a script.
Here is a sample netgroup, and I want to add user tonyz to it:
# ldapsearch -h ldapserver.com -p 389 -b ... (1 Reply)
Hi, How to pull netgroup from all servers
I think the netgroup resides in /etc/security/access.conf so I want to know how to get the list of netgroup in all the servers.
I have a jump server I can run the script from there to get the list but not sure how to do the script. Any ideas or... (1 Reply)