MOUNT_PUFFS(8) BSD System Manager's Manual MOUNT_PUFFS(8)NAME
mount_puffs -- print arguments to puffs mounts
mount_puffs -o getargs puffs mount_point
The mount_puffs program prints the kernel arguments for a puffs mount. It is typically executed by mount -vv.
SEE ALSO puffs(4), mount(8)HISTORY
The mount_puffs utility first appeared in NetBSD 6.0.
BSD January 14, 2010 BSD
Check Out this Related Man Page
RUMP_TMPFS(8) BSD System Manager's Manual RUMP_TMPFS(8)NAME
rump_tmpfs -- mount a tmpfs fictional fs with a userspace server
rump_tmpfs [options] tmpfs mountpoint
NOTE! This manual page describes features specific to the rump(3) file server. Please see mount_tmpfs(8) for a full description of the
available command line options.
The rump_tmpfs utility can be used to mount tmpfs file systems. It uses rump(3) and p2k(3) to facilitate running the file system as a server
in userspace. As opposed to mount_tmpfs(8), rump_tmpfs does not use file system code within the kernel and therefore does not require kernel
support except puffs(4). Apart from a minor speed penalty there is no downside with respect to in-kernel code.
To use rump_tmpfs via mount(8), the flags -o rump and -t tmpfs should be given. Similarly, rump_tmpfs is used instead of mount_tmpfs(8) if
``rump'' is added to the options field of fstab(5).
SEE ALSO p2k(3), puffs(3), rump(3), mount_tmpfs(8)HISTORY
The rump_tmpfs utility first appeared in NetBSD 5.0.
BSD November 21, 2010 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)