|Linux & Unix Commands - Search Man Pages
MLXCTL(8) BSD System Manager's Manual MLXCTL(8)
mlxctl -- Mylex DAC960 family management utility
mlxctl [-f dev] [-v] [-a] status [drive] [...]
mlxctl [-f dev] [-a] detach [drive] [...]
mlxctl [-f dev] [-a] check [drive] [...]
mlxctl [-f dev] rebuild channel:target
mlxctl [-f dev] cstatus
mlxctl [-f dev] rescan
mlxctl [-f dev] config
The mlxctl utility performs status monitoring and management functions for Mylex DAC960 RAID
controllers and attached devices.
The following options are available:
-a Apply the action to all drives attached to the controller.
-f dev Specify the control device to use. The default is /dev/mlx0.
-v Increased verbosity.
The following commands are available:
cstatus Display the controller's current status.
status Display the status of the specified drives. This command returns 0 if all drives
tested are online, 1 if one or more drives are critical and 2 if one or more are
rescan Re-scan the logical drive table, and attach or detach devices from the system as
detach Detach the specified drives. Drives must be unmounted and unopened for this com-
mand to succeed.
check Initiate a consistency check and repair pass on a drive that provides redundancy
(e.g., RAID1 or RAID5). This command returns immediately. The status command can
be used to monitor the progress of the check.
rebuild Rebuild onto the specified physical drive. Note that there can be only one running
rebuild operation per controller at any given time. This command returns immedi-
ately. The cstatus command can be used to monitor the progress of the rebuild.
config Write the current system drive configuration to stdout.
Display the status of drive ld3 attached to the controller mlx1:
mlxctl -f /dev/mlx1 -v status ld3
The mlxctl command first appeared in NetBSD 1.5.3, and was based on the mlxcontrol utility
found in FreeBSD.
Modifying drive configuration is not yet supported.
Some commands do not work with older firmware revisions.
Error log extraction is not yet supported.
BSD April 10, 2000 BSD
All times are GMT -4. The time now is 04:36 PM.