GROUPINFO(8) BSD System Manager's Manual GROUPINFO(8)NAME
groupinfo -- displays group information
SYNOPSIS
groupinfo [-ev] group
DESCRIPTION
The groupinfo utility retrieves the group information from the system. The groupinfo utility is only available if built with EXTENSIONS.
See group(8) for more information.
The following command line options are recognised:
-e Return 0 if the group exists, and non-zero if the group does not exist, on the system. No information is displayed. This form of
the command is useful for scripts which need to check whether a particular group name or gid is already in use on the system.
-v Perform any actions in a verbose manner.
The group argument may either be a group's name, or a gid.
EXIT STATUS
The groupinfo utility exits 0 on success, and >0 if an error occurs.
FILES
/etc/usermgmt.conf
SEE ALSO passwd(5), group(8)HISTORY
The groupinfo utility first appeared in NetBSD 1.5. It is based on the addnerd package by the same author.
AUTHORS
The groupinfo utility was written by Alistair G. Crooks <agc@NetBSD.org>.
BSD November 7, 2005 BSD
Check Out this Related Man Page
GROUPMOD(8) BSD System Manager's Manual GROUPMOD(8)NAME
groupmod -- modify an existing group on the system
SYNOPSIS
groupmod [-ov] [-g gid] [-n newname] group
DESCRIPTION
The groupmod utility modifies an existing group on the system. See group(8) for more information about EXTENSIONS. The options are as fol-
lows:
-g gid Give the numeric group identifier to be used for the new group.
-n new-group-name
Give the new name which the group shall have.
-o Allow the new group to have a gid which is already in use for another group.
-v Enable verbose mode - explain the commands as they are executed. This option is included if built with EXTENSIONS.
EXIT STATUS
The groupmod utility exits 0 on success, and >0 if an error occurs.
SEE ALSO group(5), group(8), user(8)HISTORY
The groupmod utility first appeared in NetBSD 1.5. It is based on the addnerd package by the same author.
AUTHORS
The groupmod utility was written by Alistair G. Crooks <agc@NetBSD.org>.
BSD November 7, 2005 BSD
Hi All,
Is there any utility or command to read a .gz file without GUNZIPing it?
Why I need this because of the huge size of the file. I am looking for something like zcat. Any help is aprreciated.
Thanks in Advance..
Regards,
rin... (1 Reply)
I want to search for the line with the group name and add the user into the group. The file format is the same as /etc/group
The code i wrote is
egrep "^$newGID" $group >/dev/null
FS=":"
oldData=awk -F: '{print $3}'
newData= "$oldData,$newUser"
sed -n $4/$newData $group
but a friend... (1 Reply)
Hi,
I need to search for the line with the particular group name and add the user into the group. The file format is the same as /etc/group
The code i wrote is
egrep "^$newGID" $group >/dev/null
FS=":"
oldData=awk -F: '{print $3}'
newData= "$oldData,$newUser"
sed -n $4/$newData $group... (1 Reply)
Hi All,
Second time to post on this group :)
I'm pulling my hair now 'coz I'm so dumb to produce this requirement.
Requirement: I want to run a utility by limiting the no. inside my process (mov##) to be able to use in multi streaming.
Here is my script:
--Input: "user_list.txt"... (0 Replies)
Hello gurus,
I am having trouble selecting consensus name, if any, for each group in my data.
The rules are
1. A group is defined by the first 2 columns.
2. The last column defines the name of the row within a group. If all rows within a group have the same name , we select that name as... (1 Reply)
Hi,
I need to do some section/group sorting. At the moment, I get around it by grep group by group and then re-directing to the same 'final' output file.
Below is what's been sorted so far based on the second field
$ awk -F"," '{ { print $5 " == " $6 } }' /tmp/x.csv | grep -v "^env" | grep... (2 Replies)