CRASH(8) BSD System Manager's Manual CRASH(8)NAME
crash -- examine and debug system images
crash [-M core] [-N kernel]
The crash command is used to examine and debug system images.
If run without any arguments, crash operates on the running system.
The options are as follows:
-M core Operate on the specified crash dump instead of the default /dev/mem. Crash dumps should be from the same version of the system
and same machine architecture as the running version of crash, and must be uncompressed.
-N kernel Extract the name list from the specified kernel instead of the default /dev/ksyms.
The command syntax used by crash is the same as the in-kernel debugger. See the ddb(4) manual page for more information.
Operations and facilities that require a running system, such as breakpoints, are not supported by crash.
crash does not provide pagination. However, by using the pipe symbol, output may be sent to commands available from the shell. For example:
crash> ps | more
crash> ps | grep ioflush
SEE ALSO ps(1), vmstat(1), ddb(4), pstat(8)HISTORY
The crash command appeared in NetBSD 6.0.
BSD March 7, 2009 BSD
Check Out this Related Man Page
cr_open(3) Library Functions Manual cr_open(3)NAME
cr_open() - open crash dump for reading
The library call opens a crash dump and passes back a crash dump descriptor.
The path argument points to a path name naming a crash dump directory or file, and must not exceed bytes in length.
The CRASH * to which crash_cb points is set to a crash dump descriptor, which can then be passed to the other functions to access the crash
flags is a bitmask of zero or more of the following flag values, which affect the operation of future calls to libcrash routines for this
crash dump, except for cr_verify(3), which has its own flags parameter.
The library will not attempt to verify checksums of files in the crash
dump if this flag is set.
The library will write messages to stderr during time-consuming operations
(decompressions and checksums) if this flag is set.
Returns zero for success. Other possible return values are described in libcrash(5).
The following call to opens crash dump contained in the directory and returns the crash dump descriptor For an example of reading the crash
dump see the cr_read(3) manual entry.
was developed by HP.
SEE ALSO cr_close(3), cr_perror(3), libcrash(5).
A REAL dummy question:
could someone explain to me the specifics of the <, >, >> and | symbols as they are used in Unix shells? I'm taking a bit of a crash course in this matter, and I feel this is very much a basic.
I know that | is the pipe, meaning that it will tunnel the output of the... (4 Replies)
I am very new to the world of Unix, in the middle of a crash course as I write this due to a system failure for my company. This system went down approximately 24 hours ago due to some apparent thunderstorms that passed through. The problem is that my company, like many others, has laid off... (5 Replies)
I host a couple of Call of Duty gameing servers. There are some hackers who love the crash them. When they crash them it simply causes a segmentaion fault and kills the PID. I was wondering it you could help me write a script to simply restart the program after it has been crashed. The... (9 Replies)
Plz Help me out ,,,,,, the Unix Servers i m working on ,,,Somes times run out of space in root ,,,due the generation of a file named STA ....which causes the system to crash ,,,,,
plz hlp me !!!!!!!!!!!!!!!!!!!!!!
how to find out the file ....generation causes ......
... (6 Replies)
I have a program that opens a file handle that reads a lot of logs, it uses globbing, for example ba* matches bananas.log, bank.log, etc. I have seven different names, each with several logs that I run to a grep pattern. I have subroutines for each match and a loop w/o args that processes this. ... (5 Replies)
Anyone there who has a procedure on how to crash a linux a system? We need to do some testing on our machines. And one of the test would be to crash the os. Appreciate you help. Thanks.
Sodapop (5 Replies)
I'm running Solaris 10 with a zone called "testzone"
If I do a "reboot -d" on the host, as expected the kernet panics, reboots and creates a crash dump file in /var/crash
However no crash file is created in testzone.
My question is how can I tell if a zone crashs or shuts down... (4 Replies)
I am running openSUSE 11.2 with KDE4.5 on my eMachines e525. I just did a "zypper up" on my system and it reported that Chromium was going to be updated. I agreed and the when the update was finished I shut down Chromium and started it again. It flickered on the screen for a moment and crashed.... (6 Replies)
sorry if there already a thread about this, I did a little bit of digging but haven't found exactly what I want.
I have a java application on a glassfish server who crash from time to time :D
I need a script to allert me if there's a error like "java heappspace" or "out of memory" in the... (5 Replies)
This weekend there was a sudden application crash in the server.
I did not know where to start to investigate the problem, so I first looked into the /var/adm/syslog/syslog.log, and this was what I found :
Dec 17 00:38:02 L28bi01 sshd: error: accept: No buffer space available
Dec 17... (9 Replies)
i have two aix system
-Model : P770
-OS version: AIX 6.1
-patch level : 6100-07-04-1216
-ha version : HACMP v 126.96.36.199
-host : A, B
last Wednesday, my B system suddenly went down with crash dump. after 1 minute, A system went down with crash dump. I checked the dump of A-system... (6 Replies)