CRASH(8) BSD System Manager's Manual CRASH(8)NAME
crash -- examine and debug system images
crash [-M core] [-N kernel]
The crash command is used to examine and debug system images.
If run without any arguments, crash operates on the running system.
The options are as follows:
-M core Operate on the specified crash dump instead of the default /dev/mem. Crash dumps should be from the same version of the system
and same machine architecture as the running version of crash, and must be uncompressed.
-N kernel Extract the name list from the specified kernel instead of the default /dev/ksyms.
The command syntax used by crash is the same as the in-kernel debugger. See the ddb(4) manual page for more information.
Operations and facilities that require a running system, such as breakpoints, are not supported by crash.
crash does not provide pagination. However, by using the pipe symbol, output may be sent to commands available from the shell. For example:
crash> ps | more
crash> ps | grep ioflush
SEE ALSO ps(1), vmstat(1), ddb(4), pstat(8)HISTORY
The crash command appeared in NetBSD 6.0.
BSD March 7, 2009 BSD
Check Out this Related Man Page
crash - analyze kernel dump or active system image
crash [ aps ] [ -bdvtiz ] [ -s sfile ] [ -c cfile ] [ -u addr ]
Synopsis of options -
-b Brief mode; skip general display of processes
-d Crash dump contains swap image. (default?)
-v Verbose; dump much information about each proc [future]
-t TTY structs to be dumpped
-i Incore inode table to be printed
-c FILE Provide non-standard file name for system image input
-s FILE Provide non-standard symboltable input
-u ADDR Trace a process other than currently selected one
-z Interrupt Trace displayed
aps Print PS & PC at time of interupt (doesn't do anything)
crash examines a dump of unix which it looks for in the file sysdump. It prints out the contents of the general registers, the kernel
stack and a traceback through the kernel stack. If an aps is specified, the ps and pc at time of interrupt are also printed out. The dump
of the stack commences from a "reasonable" address and all addresses are relocated to virtual addresses by using the value of kdsa6 found
in the dump.
The following options may be specified.
-b Brief mode; skip general display of processes. Only the currently selected process will be traced.
If the -c argument is found, the following argument is taken to be the name of a file containing the system image. The default is
If the -s argument is found the following argument is taken to be the name of a file, containing a symbol table which should be used
in interpreting text addresses. The default is "/unix".
Force a process to be displayed as if it were active when the crash occurred. addr is the octal address of the proc table entry.
/unix system namelist
/dev/swap swap device
/usr/sys/core core file
SEE ALSO crash(8), adb(1), ps(1), rstat(1)DIAGNOSTICS
Missing arg Unable to Open file Format Error in symbolfile
Care should be used in running crash on "/dev/mem". Things can change while crash is running; the picture it gives is only a close approx-
imation to reality.
Mike Muuss, JHU EE
John Stewart, Teledyne Geotech
March 1983 CRASH(L)
A REAL dummy question:
could someone explain to me the specifics of the <, >, >> and | symbols as they are used in Unix shells? I'm taking a bit of a crash course in this matter, and I feel this is very much a basic.
I know that | is the pipe, meaning that it will tunnel the output of the... (4 Replies)
I am very new to the world of Unix, in the middle of a crash course as I write this due to a system failure for my company. This system went down approximately 24 hours ago due to some apparent thunderstorms that passed through. The problem is that my company, like many others, has laid off... (5 Replies)
I host a couple of Call of Duty gameing servers. There are some hackers who love the crash them. When they crash them it simply causes a segmentaion fault and kills the PID. I was wondering it you could help me write a script to simply restart the program after it has been crashed. The... (9 Replies)
Plz Help me out ,,,,,, the Unix Servers i m working on ,,,Somes times run out of space in root ,,,due the generation of a file named STA ....which causes the system to crash ,,,,,
plz hlp me !!!!!!!!!!!!!!!!!!!!!!
how to find out the file ....generation causes ......
... (6 Replies)
I have a program that opens a file handle that reads a lot of logs, it uses globbing, for example ba* matches bananas.log, bank.log, etc. I have seven different names, each with several logs that I run to a grep pattern. I have subroutines for each match and a loop w/o args that processes this. ... (5 Replies)
Anyone there who has a procedure on how to crash a linux a system? We need to do some testing on our machines. And one of the test would be to crash the os. Appreciate you help. Thanks.
Sodapop (5 Replies)
I'm running Solaris 10 with a zone called "testzone"
If I do a "reboot -d" on the host, as expected the kernet panics, reboots and creates a crash dump file in /var/crash
However no crash file is created in testzone.
My question is how can I tell if a zone crashs or shuts down... (4 Replies)
I am running openSUSE 11.2 with KDE4.5 on my eMachines e525. I just did a "zypper up" on my system and it reported that Chromium was going to be updated. I agreed and the when the update was finished I shut down Chromium and started it again. It flickered on the screen for a moment and crashed.... (6 Replies)
sorry if there already a thread about this, I did a little bit of digging but haven't found exactly what I want.
I have a java application on a glassfish server who crash from time to time :D
I need a script to allert me if there's a error like "java heappspace" or "out of memory" in the... (5 Replies)
This weekend there was a sudden application crash in the server.
I did not know where to start to investigate the problem, so I first looked into the /var/adm/syslog/syslog.log, and this was what I found :
Dec 17 00:38:02 L28bi01 sshd: error: accept: No buffer space available
Dec 17... (9 Replies)
i have two aix system
-Model : P770
-OS version: AIX 6.1
-patch level : 6100-07-04-1216
-ha version : HACMP v 18.104.22.168
-host : A, B
last Wednesday, my B system suddenly went down with crash dump. after 1 minute, A system went down with crash dump. I checked the dump of A-system... (6 Replies)