PAM_GUEST(8) BSD System Manager's Manual PAM_GUEST(8)NAME
pam_guest -- Guest PAM module
[service-name] module-type control-flag pam_guest [arguments]
The guest service module for PAM allows guest logins. If successful, the pam_guest module sets the PAM environment variable GUEST to the
login name. The application can check this variable using pam_getenv(3) to differentiate guest logins from normal logins.
The following options may be passed to the pam_guest module:
guests=list Comma-separated list of guest account names. The default is ``guest''. A typical value for ftpd(8) would be
nopass Omits the password prompt if the target account is on the list of guest accounts.
pass_as_ruser The password typed in by the user is exported as the PAM_RUSER item. This is useful for applications like ftpd(8) where guest
users are encouraged to use their email address as password.
pass_is_user Requires the guest user to type in the guest account name as password.
SEE ALSO pam_get_item(3), pam_getenv(3), pam.conf(5), pam(8)AUTHORS
The pam_guest module and this manual page were developed for the FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research Division
of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (``CBOSS''), as part of the DARPA CHATS research program.
BSD May 26, 2003 BSD
Check Out this Related Man Page
PAM_FTPUSERS(8) BSD System Manager's Manual PAM_FTPUSERS(8)NAME
pam_ftpusers -- ftpusers PAM module
[service-name] module-type control-flag pam_ftpusers [options]
The ftpusers service module for PAM provides functionality for only one PAM category: account management. In terms of the module-type param-
eter, this is the ``account'' feature.
Ftpusers Account Management Module
The ftpusers account management component (pam_sm_acct_mgmt()), succeeds if and only if the user is listed in /etc/ftpusers.
The following options may be passed to the authentication module:
debug syslog(3) debugging information at LOG_DEBUG level.
no_warn suppress warning messages to the user. These messages include reasons why the user's authentication attempt was declined.
disallow reverse the semantics; pam_ftpusers will succeed if and only if the user is not listed in /etc/ftpusers.
SEE ALSO ftpusers(5), pam.conf(5), ftpd(8), pam(8)AUTHORS
The pam_ftpusers module and this manual page were developed for the FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research Divi-
sion of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (``CBOSS''), as part of the DARPA CHATS research program.
The current version of this module parses an older format of the ftpusers(5) file and should not be used. ftpd(8) will keep using its built-
in ftpusers(5) parsing code until the parser code in the pam module is fixed.
BSD February 27, 2005 BSD
Hello there :)
I need to know how to get a guest book up and running on my server. My ISP does allow CGI scripts to be run, and the one I have working at the moment (an email form)
runs OK as a pop-up window on my home page.
I have uploaded two files:
1)... (4 Replies)
I recently installed RedHat9 on my laptop as a guest OS. My host OS is Windows2000 and I am using VMWare to toggle between two OSs.
Any time I try to connect to internet from RedHat environment using Mozilla, internet acces does not work. At the office, after connecting my laptop to our... (7 Replies)
what is the default password for those build-in accounts, such as adm, sys, dhcp, oracle, guest?
if not set, can they be used to login? is that a security problem? how are they designed to be used?
thanks! (5 Replies)
I have a host os Windows 7 ultimate in place where virtual box is installed.
Now in virtual box I have installed solaris 10.
There is internet connection present in host windows 7 still I am not able to access internet in solaris 10.
Please help to configure solaris so that internet can be... (12 Replies)
I have a weird problem.
I'm doing guest customization for Linux guests. During this process, I change the hostname, etc. For changing the hostname, I edit the /etc/sysconfig/network file and change the HOSTNAME field. I also add a new property called DHCP_HOSTNAME as my IP's are all... (5 Replies)
I am using win7 on my PC and installed VMware on it on which i am running linux
I am unable to ping my linux guest from my win machine,
but i can ping my windows host from linux guest :
Below is my system configuration
root@localhost ~]# ifconfig
eth0 Link... (9 Replies)
I've installed a Virtualbox on my computer, inside the VB i'm running RedHat.
So my problems it's that i need to run the scripts runasroot.sh to install the guest addiont, i'm doing this by console. I wrote chmod 775 ./runasroot.sh but doesn't works. I'm login as root user.
Any... (8 Replies)
I'm writing scripts to check for compliance with the DISA STIG. Several items refer to manually click-click-clicking to verify settings regarding LDAP or accounts like guest account disabled, "Allow Guests to connect to shared folders", "Display login window as:", "Show input menu in login... (7 Replies)
Solaris for Sparc 11.1 with the latest patches. Created a Guest LDOM with two vnet's net0 and net1, installed a guest whole root, ip exclusive zone that I want to be able to utilize DHCP. I have been able to create the zone but unable to get it to boot because I am unable to assign an anet to it.... (4 Replies)
Failed to open the CD/DVD image /usr/lib/virtualbox/additions/VBoxGuestAdditions.iso.
Could not get the storage format of the medium '/usr/lib/virtualbox/additions/VBoxGuestAdditions.iso' (VERR_NOT_SUPPORTED).
Result Code: VBOX_E_IPRT_ERROR (0x80BB0005)
Interface: IMedium... (9 Replies)
Hello All ,
Hope you are doing good.
I have a netgear router + modem in my home . My roommate brought his friend as a guest , he is downloading stuff like crazy day and night , while talking with my friend in India got to know there is concept called BANDWIDTH LIMIT wherein i can... (4 Replies)
I usually run bash to get file from ftp using command below (user : nobody, password : guest)
/usr/bin/ftp -in 188.8.131.52 << END
user nobody guest
But in this case,... (9 Replies)
New to this forum.
I have just been reading through a historical thread about some issues with IPMP.
Some tips from "Peasant" where very useful. Please see below
"Just couple of more hints regarding VM.
For VDS, use one VDS - one guest LDOM, don't put everything in primary-vds.... (9 Replies)
I plan to use a small SPARC Netra T4-1 as a VM server with a primary domain and 2 guest domains. The primary has MPIO configured (4 paths to SAN storage). When a LUN is exported and added to a guest domain, does the single disk server defined on the primary handle the multipathing for the guest... (6 Replies)