ACCTON(8) BSD System Manager's Manual ACCTON(8)NAME
accton -- enable/disable system accounting
With an argument naming an existing file, accton causes system accounting information for every process executed to be placed at the end of
the file. If no argument is given, accounting is turned off.
The default accounting file is /var/account/acct. Typically, accounting is enabled by rc scripts during the boot process. In NetBSD, one
may enable accounting by setting the variable ``accounting'' to ``YES'' in /etc/rc.conf.
Note that, traditionally, the system accounting log file can not be rotated cleanly by newsyslog(8). Instead, a default installation of
NetBSD rotates /var/account/acct using the /etc/daily script.
/var/account/acct Default accounting file.
SEE ALSO lastcomm(1), acct(5), sa(8)BSD January 23, 2008 BSD
Check Out this Related Man Page
acctprc(8) System Manager's Manual acctprc(8)NAME
acctprc1, acctprc2, accton - Perform process-accounting procedures
The three acctprc commands, acctprc1, acctprc2, and accton, are used in the runacct shell procedure to produce process-accounting reports.
The acctprc1 command is used to read records from standard input that are in a format defined by the acct structure in the
/usr/include/sys/acct.h header file. This process adds the login names that correspond to user IDs, and then writes corresponding ASCII
records to standard output. For each process, the record format includes the following seven unheaded columns: The user ID column includes
both traditional and assigned user identification numbers listed in the /etc/passwd file. The login name is the one used for the user ID
in the /etc/passwd file. The number of seconds the process consumed when executed during prime-time hours. Prime-time and nonprime-time
hours are defined in the /usr/sbin/acct/holidays file. The number of seconds the process consumed when executed during nonprime-time
hours. Total number of characters transferred. Total number of blocks read and written. Mean memory size (in kilobyte units).
When specified, InFile contains a list of login sessions in a format defined by the utmp structure in the /usr/include/utmp.h header file.
The login session records are sorted according to user ID and login name. When InFile is not specified, acctprc1 gets login names from the
password file /etc/passwd. The information in InFile is used to distinguish different login names that share the same user ID.
The acctprc2 command reads, from standard input, the records written by acctprc1, summarizes them according to user ID and name, and writes
sorted summaries to standard output as total accounting records in the tacct format (see the acctmerg command).
When no parameters are specified with the accton command, account processing is turned off. When you specify an existing OutFile file,
process accounting is turned on, and the kernel adds records to that file. You must specify an Outfile to start process accounting. Many
shell script procedures expect the file name /var/adm/pacct, the standard process-accounting file.
To add a user name to each process-accounting record in a binary file and then write these modified binary-file records to an ASCII file
named out.file, enter the following line to an accounting shell script:
/usr/sbin/acct/acctprc1 < /var/adm/pacct >out.file
A user name is added to each record. The raw data in the pacct file is converted to ASCII and added to file out.file. To produce a
total binary accounting record of the ASCII output file out.file produced in example 1, enter the following line to an accounting
/usr/sbin/acct/acctprc2 < out.file > /var/adm/acct/nite/daytacct
The resulting binary total accounting file, written in the acct format, contains records sorted by user ID. This sorted user ID
file, is usually merged with other total accounting records when an acctmerg command is processed to produce a daily summary
accounting record called /var/adm/acct/sum/daytacct. To turn on process accounting, enter:
/usr/sbin/acct/accton /var/adm/pacct To turn off process accounting, enter:
Specifies the command path. Specifies the command path. Specifies the command path.
Commands: acct(8), acctcms(8), acctmerg(8), runacct(8)
Functions: acct(2) delim off