veriexec(5) [netbsd man page]
VERIEXEC(5) BSD File Formats Manual VERIEXEC(5) NAME
veriexec -- format for the Veriexec signatures file DESCRIPTION
Veriexec loads entries to the in-kernel database from a file describing files to be monitored and the type of monitoring. This file is often referred to as the 'signatures database' or 'signatures file'. The signatures file can be easily created using veriexecgen(8). SIGNATURES DATABASE FORMAT
The signatures database has a line based structure, where each line has several fields separated by white-space (space, tabs, etc.) taking the following form: path type fingerprint flags The description for each field is as follows: path The full path to the file. White-space characters can be escaped if prefixed with a ''. type Type of fingerprinting algorithm used for the file. Requires kernel support for the specified algorithm. List of fingerprinting algorithms supported by the kernel can be obtained by using the following command: # sysctl kern.veriexec.algorithms fingerprint The fingerprint for the file. Can (usually) be generated using the following command: % cksum -a <algorithm> <file> flags Optional listing of entry flags, separated by a comma. These may include: direct Allow direct execution only. Execution of a program is said to be ``direct'' when the program is invoked by the user (either in a script, manually typing it, etc.) via the execve(2) syscall. indirect Allow indirect execution only. Execution of a program is said to be ``indirect'' if it is invoked by the kernel to interpret a script (``hash-bang''). file Allow opening the file only, via the open(2) syscall (no execution is allowed). untrusted Indicate that the file is located on untrusted storage and its fingerprint evaluation status should not be cached, but rather re-calculated each time it is accessed. Fingerprints for untrusted files will always be evaluated on load. To improve readaibility of the signatures file, the following aliases are provided: program An alias for ``direct''. interpreter An alias for ``indirect'' script An alias for both ``direct'' and ``file''. library An alias for both ``file'' and ``indirect''. If no flags are specified, ``direct'' is assumed. Comments begin with a '#' character and span to the end of the line. SEE ALSO
veriexec(4), security(7), veriexec(8), veriexecctl(8), veriexecgen(8) HISTORY
veriexec first appeared in NetBSD 2.0. AUTHORS
Brett Lymn <blymn@NetBSD.org> Elad Efrat <elad@NetBSD.org> BSD
March 18, 2011 BSD
Check Out this Related Man Page
glutInit(3GLUT) GLUT glutInit(3GLUT) NAME
glutInit - initialize the GLUT library. SYNTAX
#include <GLUT/glut.h> void glutInit(int *argcp, char **argv); ARGUMENTS
argcp A pointer to the program's unmodified argc variable from main. Upon return, the value pointed to by argcp will be updated, because glutInit extracts any command line options intended for the GLUT library. argv The program's unmodified argv variable from main. Like argcp, the data for argv will be updated because glutInit extracts any command line options understood by the GLUT library. DESCRIPTION
glutInit will initialize the GLUT library and negotiate a session with the window system. During this process, glutInit may cause the ter- mination of the GLUT program with an error message to the user if GLUT cannot be properly initialized. Examples of this situation include the failure to connect to the window system, the lack of window system support for OpenGL, and invalid command line options. glutInit also processes command line options, but the specific options parse are window system dependent. X IMPLEMENTATION NOTES
The X Window System specific options parsed by glutInit are as follows: -display DISPLAY Specify the X server to connect to. If not specified, the value of the DISPLAY environment variable is used. -geometry WxH+X+Y Determines where window's should be created on the screen. The parameter following -geometry should be formatted as a standard X geometry specification. The effect of using this option is to change the GLUT initial size and initial position the same as if glutInitWindowSize or glutInitWindowPosition were called directly. -iconic Requests all top-level windows be created in an iconic state. -indirect Force the use of indirect OpenGL rendering contexts. -direct Force the use of direct OpenGL rendering contexts (not all GLX implementations support direct rendering contexts). A fatal error is generated if direct rendering is not supported by the OpenGL implementation. If neither -indirect or -direct are used to force a particular behavior, GLUT will attempt to use direct rendering if possible and otherwise fallback to indirect rendering. -gldebug After processing callbacks and/or events, check if there are any OpenGL errors by calling glGetError. If an error is reported, print out a warning by looking up the error code with gluErrorString. Using this option is helpful in detecting OpenGL run-time errors. -sync Enable synchronous X protocol transactions. This option makes it easier to track down potential X protocol errors. SEE ALSO
glutCreateWindow, glutInitWindowPosition, glutInitWindowSize, glutMainLoop AUTHOR
Mark J. Kilgard (mjk@nvidia.com) GLUT
3.7 glutInit(3GLUT)