REMOTE(5) BSD File Formats Manual REMOTE(5)
remote -- remote host description file
The systems known by tip(1) and their attributes are stored in an ASCII file which is struc-
tured somewhat like the termcap(5) file. Each line in the file provides a description for a
single system. Fields are separated by a colon (``:''). Lines ending in a \ character with
an immediately following newline are continued on the next line.
The first entry is the name(s) of the host system. If there is more than one name for a
system, the names are separated by vertical bars. After the name of the system comes the
fields of the description. A field name followed by an `=' sign indicates a string value
follows. A field name followed by a `#' sign indicates a following numeric value.
Entries named ``tip*'' and ``cu*'' are used as default entries by tip(1), and the cu(1)
interface to tip(1), as follows. When tip(1) is invoked with only a phone number, it looks
for an entry of the form ``tip300'', where 300 is the baud rate with which the connection is
to be made. When the cu(1) interface is used, entries of the form ``cu300'' are used.
Capabilities are either strings (str), numbers (num), or boolean flags (bool). A string
capability is specified by capability=value; for example, ``dv=/dev/harris''. A numeric
capability is specified by capability#value; for example, ``xa#99''. A boolean capability
is specified by simply listing the capability.
at (str) Auto call unit type.
br (num) The baud rate used in establishing a connection to the remote host. This is a
decimal number. The default baud rate is 300 baud.
cm (str) An initial connection message to be sent to the remote host. For example, if
a host is reached through a port selector, this might be set to the appropriate
sequence required to switch to the host.
cu (str) Call unit if making a phone call. Default is the same as the `dv' field.
dc (bool) This host is directly connected, and tip should not expect carrier detect to
be high, nor should it exit if carrier detect drops.
di (str) Disconnect message sent to the host when a disconnect is requested by the
du (bool) This host is on a dial-up line.
dv (str) UNIX device(s) to open to establish a connection. If this file refers to a
terminal line, tip(1) attempts to perform an exclusive open on the device to ensure
only one user at a time has access to the port.
el (str) Characters marking an end-of-line. The default is NULL. `~' escapes are only
recognized by tip(1) after one of the characters in `el', or after a carriage-
fs (str) Frame size for transfers. The default frame size is equal to BUFSIZ.
hd (bool) The host uses half-duplex communication, local echo should be performed.
hf (bool) Use hardware (RTS/CTS) flow control.
ie (str) Input end-of-file marks. The default is NULL.
oe (str) Output end-of-file string. The default is NULL. When tip(1) is transferring
a file, this string is sent at end-of-file.
pa (str) The type of parity to use when sending data to the host. This may be one of
even, odd, none, zero (always set bit 8 to zero), one (always set bit 8 to one).
The default is even parity.
pn (str) Telephone number(s) for this host. If the telephone number field contains an
@ sign, tip(1) searches the file /etc/phones file for a list of telephone numbers;
tc (str) Indicates that the list of capabilities is continued in the named description.
This is used primarily to share common capability information.
Here is a short example showing the use of the capability continuation feature:
/etc/remote The remote host description file resides in /etc.
The remote file format appeared in 4.2BSD.
BSD June 5, 1993 BSD