|Linux & Unix Commands - Search Man Pages
RANLIB(5) BSD File Formats Manual RANLIB(5)
ranlib -- a.out archive (library) table-of-contents format
The archive table-of-contents command ranlib creates a table of contents for archives, con-
taining object files, to be used by the link-editor ld(1). It operates on archives created
with the utility ar(1).
The ranlib function prepends a new file to the archive which has three separate parts. The
first part is a standard archive header, which has a special name field, "__.SYMDEF".
The second part is a ``long'' followed by a list of ranlib structures. The long is the
size, in bytes, of the list of ranlib structures. Each of the ranlib structures consists of
a zero based offset into the next section (a string table of symbols) and an offset from the
beginning of the archive to the start of the archive file which defines the symbol. The
actual number of ranlib structures is this number divided by the size of an individual ran-
The third part is a ``long'' followed by a string table. The long is the size, in bytes of
the string table.
The <ranlib.h> header file, and the ranlib manual page, do not describe the table-of-con-
tents used by ELF systems, which is that from the AT&T System V Release 4 UNIX ABI.
BSD June 6, 1993 BSD
All times are GMT -4. The time now is 07:54 PM.