NetBSD 6.1.5 - man page for pkg_install.conf (netbsd section 5)
|Linux & Unix Commands - Search Man Pages
PKG_INSTALL.CONF(5) BSD File Formats Manual PKG_INSTALL.CONF(5)
pkg_install.conf -- configuration file for package installation tools
The file pkg_install.conf contains system defaults for the package installation tools as a
list of variable-value pairs. Each line has the format VARIABLE=VALUE. If the value con-
sists of more than one line, each line is prefixed with VARIABLE=.
The current value of a variable can be checked by running
pkg_admin config-var VARIABLE
Some variables are overriden by environmental variables of the same name. Those are marked
The following variables are supported:
Space-separated list of licenses packages are allowed to carry. License names are
Force the use of active FTP.
Cache directory listenings in memory. This avoids retransfers of the large direc-
tory index for HTTP and is enabled by default.
Path to the file containing the certificates used for validating binary packages. A
package is trusted when a certificate chain ends in one of the certificates con-
tained in this file. The certificates must be PEM-encoded.
Analogous to CERTIFICATE_ANCHOR_PKGS. The pkg-vulnerabilities is trusted when a
certificate chain ends in one of the certificates contained in this file.
Path to a file containing additional certificates that can be used for completing
certificate chains when validating binary packages or pkg-vulnerabilities files.
Check the license conditions of packages before installing them. Supported values
no The check is not performed.
yes The check is performed if the package has license conditions set.
always Passing the license check is required. Missing license conditions
are considered an error.
During vulnerability checks, consider packages that have reached end-of-life as vul-
nerable. This option is enabled by default.
Check for vulnerabilities when installing packages. Supported values are:
never No check is performed.
always Passing the vulnerability check is required. A missing pkg-vulnera-
bilities file is considered an error.
interactive The user is always asked to confirm installation of vulnerable pack-
Limit the global connection cache to this value. For FTP this is the number of ses-
sions without active command. For HTTP this is the number of connections open with
Like CONFIG_CACHE_CONNECTIONS, but limit the number of connections to the host as
well. See fetch(3) for further details
Space-separated list of common Free and Open Source licenses packages are allowed to
carry. The default value contains all OSI approved licenses in pkgsrc on the date
pkg_install was released. License names are case-sensitive.
GPG Path to gpg(1), which can be used to verify the signature in the pkg-vulnerabilities
file when running
pkg_admin check-pkg-vulnerabilities -s
pkg_admin fetch-pkg-vulnerabilities -s
It can also be used to verify and sign binary packages.
Non-default keyring to use for verifying GPG signatures of pkg-vulnerabilities.
Non-default keyring to use for signing packages with GPG.
Non-default keyring to use for verifying GPG signature of packages.
User-id to use for signing packages.
Use direct connections and ignore FTP_PROXY and HTTP_PROXY.
One line per advisory which should be ignored when running
The URL from the pkg-vulnerabilities file should be used as value.
Location of the packages database. This option is always overriden by the argument
of the -K option.
Search path for packages. The entries are separated by semicolon. Each entry spec-
ifies a directory or URL to search for packages.
Location of the package reference counts database directory. The default value is
Directory name in which the pkg-vulnerabilities file resides. Default is
URL which is used for updating the local pkg-vulnerabilities file when running
The default location is ftp.NetBSD.org using HTTP. Note: Usually, only the compres-
sion type should be changed. Currently supported are uncompressed files and files
compressed by bzip2(1) (.bz2) or gzip(1) (.gz).
Log details of network IO to stderr.
Set trust level used when installation. Supported values are:
never No signature checks are performed.
always A valid signature is required. If the binary package can not be ver-
ified, the installation is terminated
trusted A valid signature is required. If the binary package can not be ver-
ified, the user is asked interactively.
interactive The user is always asked interactively when installing a package.
/etc/pkg_install.conf Default location for the file described in this manual page.
pkg_add(1), pkg_admin(1) pkg_create(1), pkg_delete(1), pkg_info(1)
BSD November 13, 2010 BSD
All times are GMT -4. The time now is 07:40 PM.