OVERVIEW.FMT(5) File Formats Manual OVERVIEW.FMT(5)NAME
overview.fmt - format of news overview database
The file /etc/news/overview.fmt specifies the organization of the news overview database. Blank lines and lines beginning with a number
sign (``#'') are ignored. The order of lines in this file is important; it determines the order in which the fields will appear in the
Most lines will consist of an article header name, optionally followed by a colon. A trailing set of lines can have the word ``full''
appear after the colon; this indicates that the header should appear as well as its value.
If this file is changed, it is usually necessary to rebuild the existing overview database using expireover(8) after removing all existing
The default file, show below, is compatible with Geoff Collyer's ``nov'' package:
## Some newsreaders get better performance if Xref is present
Written by Rich $alz <email@example.com> for InterNetNews. Intended to be compatible with the nov package written by Geoff Collyer
<firstname.lastname@example.org>. This is revision 1.6, dated 1996/09/06.
Check Out this Related Man Page
OVERCHAN(8) System Manager's Manual OVERCHAN(8)NAME
overchan - update the news overview database
overchan [ -D dir ] [ -c ] [ file... ]
Overchan reads article data from files or standard input if none are specified. (A single dash in the file list means to read standard
input.) It uses this information to update the news overview database. Overchan is designed to be used by InterNetNews or the C News
``mkov'' packages to update the database as the articles come in. The database for each newsgroup is stored in a file named .overview in a
newsgroup directory within the overview database tree.
Overchan locks the database file (by locking an auxiliary file) before appending the new data. To purge data after articles have been
expired, see expireover(8).
By default, overchan processes its input as an INN overview stream written as a ``WO'' entry in the newsfeeds(5) file, for example:
This data consists of a line of text, separated into two parts by a tab. The first part is a list of all relative pathnames where the
article has been written, with a single space between entries. The second part is the data to be written into the overview file, except
that the initial article number is omitted. The data in the overview files should be expired by running expireover(8). This is normally
done by adding the ``expireover'' flag to the news.daily(8) invocation.
OPTIONS -c To process the output of the mkov(8) program, use the ``-c'' flag. This format is described in the ``nov'' distribution.
-D The ``-D'' flag can be used to specify where the databases are stored. The default directory is /var/spool/news/over.view.
Written by Rob Robertson <email@example.com> and Rich $alz <firstname.lastname@example.org> for InterNetNews. This is revision 1.9, dated
SEE ALSO expireover(8), news.daily(8), newsfeeds(5), newsoverview(5), newsoverview(8).
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)