|Linux & Unix Commands - Search Man Pages
GENASSYM.CF(5) BSD File Formats Manual GENASSYM.CF(5)
genassym.cf -- assym.h definition file
The genassym.cf file is used by genassym(1) to make constant C expressions known to assem-
bler source files. Lines starting with '#' are discarded by genassym(1). Lines starting
with include, ifdef, if, else or endif are preceded with '#' and passed otherwise unmodified
to the C compiler. Lines starting with quote get passed on with the quote command removed.
The first word after a define command is taken as a CPP identifier and the rest of the line
has to be a constant C expression. The output of genassym(1) will assign the numerical value
of this expression to the CPP identifier. export X is a shorthand for define X X. struct X
remembers X for the member command and does a define X_SIZEOF sizeof(X). member X does a
define X offsetof(<last struct>, X). config <ctype> <gcc constraint> <asm print modifier>
can be used to customize the output of genassym(1). When producing C output, values are
casted to <ctype> (default: long) before they get handed to printf. <gcc constraint>
(default: n) is the constraint used in the __asm__ statements. <asm print modifier>
(default: empty) can be used to force gcc to output operands in different ways then normal.
The "a" modifier e.g. stops gcc from emitting immediate prefixes in front of constants for
the i386 and m68k port.
The genassym.cf file appeared in NetBSD 1.3.
BSD August 18, 2005 BSD
All times are GMT -4. The time now is 09:22 PM.