VIRT(4) BSD Kernel Interfaces Manual VIRT(4)NAME
virt -- rump virtual network interface
SYNOPSIS
#include <rump/rump.h>
int
rump_pub_virtif_create(int num);
DESCRIPTION
The virt interface acts as a link between a rump virtual kernel and a host tap(4) interface. Interface number <n> always corresponds with
the host tap interface tap<n>. All data sent by virt is written into /dev/tap<n> and all data read from /dev/tap<n> is passed as Ethernet
input to the rump virtual kernel.
A virt interface can be created in two ways:
o Programmatically by calling rump_pub_virtif_create().
o Dynamically at runtime with ifconfig(8) or equivalent using the create command.
Destroying a virt interface is possible only through ifconfig(8) destroy.
The host's tap(4) interface can be further bridged with hardware interfaces to provide full Internet access to a rump kernel.
SEE ALSO rump(3), bridge(4), tap(4), brconfig(8), ifconfig(8)BSD November 15, 2010 BSD
Check Out this Related Man Page
RUMP.HALT(1) BSD General Commands Manual RUMP.HALT(1)NAME
rump.halt -- halt a rump kernel
SYNOPSIS
rump.halt [-dhn]
DESCRIPTION
The rump.halt utility exits a rump kernel. The file system cache, if present, is flushed. Since a rump kernel does not control its clients,
they are not directly affected by rump.halt. However, they will be unable to request further services from the halted rump kernel.
The options are as follows:
-d Create a core dump. The core file is saved according to standard userland program coredump rules, and can be later examined with a
debugger.
-h By default the process hosting the rump kernel exits. Using this option shuts down rump kernel activity, but does not cause the
hosting process to exit.
-n Do not flush the file system cache. This option should be used with extreme caution. It can be used if a virtual disk or a virtual
processor is virtually on fire.
SEE ALSO rump(3)HISTORY
The rump.halt command appeared in NetBSD 6.0.
CAVEATS
While using -h makes it impossible to issue further system calls, it does not necessarily stop all activity in a rump kernel. It is recom-
mended this option is used only for debugging purposes.
BSD December 12, 2010 BSD
OS - HP-UX B.10.20 A 9000/777
Anyone know how to set up a virtual interface on HP-UX?
I've looked quickly through docs.hp.com and searched this site. No luck. And my HP Guru is sleeping today. (4 Replies)
if reader has used linux
then u may be knowing that when we type
a character and press tap twice the shell displays
the commands starting from those char's
is it possible to program it in unix (1 Reply)
Unix is great at giving you power were you need it, but what a pain in the rump when you just want to do such a simple thing like file management. I'm going back to Windows, crashing is frustrating, needing to spend 30 min just to zip a file up is crazy. (3 Replies)
Hello all,
I want to add a new virtual interface on HP-UX B.11.11 U 9000/800 box.
I know that ifconfig can be used to add the Virtual interface.
BUt i do not know the exact syntax. it some times gives plumb error if i try to add
# ifconfig vif0 10.1.10.1 up
plumb error: No such file... (3 Replies)
I know that I could use the
#ifconfig hme0 plumb
to activate the network interface.
However, how can I know the name of the interface e.g. hme0 before I could use the ifconfig to plumb it up?
I know there is a command (but I forgot it) to use in the Sparc version when you are in the... (7 Replies)
Hello,
I am using unix shell from a Unix emulator called ZOC. Basically, I checked my jobs using the command 'chkcpu'. What I get is something like this:
** cfdlab17 **
PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND... (1 Reply)
hi,
can some body in helping me in finding the virtual ip of the aix machine
using ifconfig.
I tried ifconfig -a but there could be any interface name so finding that out would be difficult.
So colud anyone suggest me some option.
thanks (2 Replies)
Hi all
i had two interface
ce0 and ce5
but when i run the ifconfig, it show me alot of extra virtual interface, may i know how to remove it?
# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
inet 127.0.0.1 netmask ff000000
ce0:... (2 Replies)
Hello,
I am trying to understand the VIRT field that shows in the TOP command output. I have a users application that appears to be leaking memory. I see that the field VIRT in the top output is showing 55.8g.
The question is where is that getting stored? The disk does not appear to have... (7 Replies)
Hi,
Again a question about virt-install.
Someone knows how to add hardware in the virt-install command?
I put the first disk with --disks path=/.... but I need a second disk and I don't know how to include it?
Thanks (2 Replies)
Gents,
I will like to print continues names according to a range of numbers
example
first number
1000
last number
1005
I would like to get the following result
tape1000 tape1001 tape 1002 tape1003 tape1004 tape1005.
Thanks for your support. (4 Replies)
HI Community,
my server has more than 15 zones and each one is having virtual interface of 10G adapter (qlge0)
if the filter the output of ifconfig -a | grep inet, it's showing all interfaces including virtual.
i have take first like from the output and assumed that as my main ip
is... (3 Replies)
I have a virtual (vmware player) on which i have two small RHEL 6.7 servers and two win7pro 64 bit guest nodes running.
#virt. host issue: accessible remotely but difficulty joining domain.
The virtual host itself uses static IP and it is accessible. It is using win 7 pro 64 bit, as its host... (2 Replies)
Hi All,
I have a java process which is showing high virtual memory utilization in client server. But the same process is showing comparitively lesser virtual memory consumption. I understand that virtual memory shown is not of much importance for the general user in normal condition, my client... (2 Replies)
Note: Newbie to IBM virtualization :-)
Query: Created a new AIX7.1 lpar on a system with same config as one before however the new one is having issues going out to physical network.
Now on comparison the only thing which differs between these two machines is an additional en1 and ent1 shown... (7 Replies)