UTS(4) BSD Kernel Interfaces Manual UTS(4)NAME
uts -- USB generic touchscreens
SYNOPSIS
uts* at uhidev? reportid ?
wsmouse* at uts?
DESCRIPTION
The uts driver provides support for USB touchscreens, otherwise known as Touch Digitizer devices. Access to panel events is through the
wsmouse(4) driver.
SEE ALSO uhidev(4), wsmouse(4)HISTORY
The uts driver was written by Pierre Pronchery for NetBSD. The uts driver appeared in NetBSD 6.0.
BUGS
uts currently does not support calibration. Also, not all NetBSD-supplied X servers support the absolute position events it generates.
BSD January 16, 2012 BSD
Check Out this Related Man Page
WSMOUSE(4) BSD Kernel Interfaces Manual WSMOUSE(4)NAME
wsmouse -- generic mouse support in wscons
SYNOPSIS
wsmouse* at pms? mux 0
(PS/2 mouse, including ``IntelliMouse''-compatible wheel mice)
wsmouse* at ums? mux 0
(USB mouse)
wsmouse* at uts? mux 0
(USB touchscreen)
wsmouse* at lms? mux 0
(Logitech bus mouse, i386 only)
wsmouse* at mms? mux 0
(Microsoft InPort mouse, i386 only)
wsmouse0 at ams? mux 0
(Apple ADB mouse)
wsmouse* at btms? mux 0
(Bluetooth mouse)
wsmouse* at lkms? mux 0
(DEC VSXXX serial mice)
DESCRIPTION
The wsmouse driver is an abstraction layer for mice within the wscons(4) framework. It is attached to the hardware specific mouse drivers
and provides a character device interface which returns struct wscons_event via read(2). For use with X servers, ``mouse events'' can be
generated.
The wsconsctl(8) utility gives access to several configurable details that affect this driver.
Ioctls
The following ioctl(2) calls are provided by the wsmouse driver or by devices which use it. Their definitions are found in
dev/wscons/wsconsio.h.
WSMOUSEIO_GETREPEAT (struct wsmouse_repeat)
Retrieve the current automatic button repeating configuration. The structure returned is as follows:
struct wsmouse_repeat {
unsigned long wr_buttons;
unsigned int wr_delay_first;
unsigned int wr_delay_decrement;
unsigned int wr_delay_minimum;
};
The wr_buttons field is a bit mask that specifies which buttons send press and release events periodically while they are phys-
ically held down. The least significant bit corresponds to button 0.
The other three fields describe the frequency upon which these automatic events are sent. wr_delay_first specifies the mil-
liseconds before the first repeated event is sent. wr_delay_decrement is used to calculate the delay between the most recently
generated event and the forthcoming one: the previous delay is taken and it is decreased by the value given in this variable.
wr_delay_minimum specifies the minimum delay, in milliseconds, between two consecutive events.
WSMOUSEIO_SETREPEAT (struct wsmouse_repeat)
Set the automatic button repeating configuration. See WSMOUSEIO_GETREPEAT above for more details.
WSMOUSEIO_SETVERSION (int)
Set the wscons_event protocol version. The default is 0 for binary compatibility. The latest version is always available as
WSMOUSE_EVENT_VERSION, and is currently 1. All new code should use a call similar to the below to ensure the correct version
is returned.
int ver = WSMOUSE_EVENT_VERSION;
if (ioctl(fd, WSMOUSEIO_SETVERSION, &ver) == -1)
err(EXIT_FAILURE, "cannot set version");
FILES
/dev/wsmouse*
/usr/include/dev/wscons/wsconsio.h.
SEE ALSO btms(4), lms(4), mms(4), pms(4), uep(4), ums(4), uts(4), wscons(4), wsmux(4), moused(8), wsconsctl(8), wsmoused(8), wsmouse(9)BSD May 27, 2012 BSD
Hi All,
I need some help with multiple cut and paste, at the moment I have a shell script that uses the following cuts ( this is just some)
cut -c1-92 WAITING > col1 .....etc etc etc
cut -c93-98 WAITING > col17 # blank_spaces
cut -c99-104 WAITING > col18 # Date
cut -c105... (12 Replies)
Hi,
I have a script that takes the contents of another file as inputs. Its assumed that there are 3 values in the input file that are seperated by '|'. I have to check in my script, whether the filed seperator used in the input file is '|' or not. If its not a '|' I have to print a error... (13 Replies)
Hello,
I think its a sinple query but somehow i m stucked up here...
I am trying to enter n number of inputs from the user and write them in
an input file ie row wise...
I tried standard commands like
$echo "enter the inputs for the file"
$read var1 var2 var3 var4
test1 test2... (14 Replies)
if my user has to enter the name of months to carry out a search how can I limit the input values to only the month names and nothing else?
so far my input criteria for the user is this:
i would like it so the user can only enter the months in the way i have stated. otherwise they would... (11 Replies)
Every day i ftp tar.gz a file from the production server to a back up machine.. This task creates way to much traffic on the network at the end of the day and puts and undo load on the production machine during operation hours. i would like to create a script that would automatically fire off the... (36 Replies)
Hi Friends ,
Sorry if this is a repeated question ,
The input file contains 5 lines , so the the values of the variables i and count should b
i=5;
count=15
but the variables are not updating , the value of variables showing i=0 and count =0 only.:mad:
can any1 help me please. (11 Replies)
Hi Jim,
The following script is in working state. But i m having one more problem with awk cmd. Could you tell me how to use any variable inside awk or how to take any variable value outside awk.
My problem is i want to maintain one property file in which i am declaring variable value into that... (12 Replies)
Hi all.
I have an expect script which for walks across servers, checks freespace and provides sorted list of biggest files
#!/usr/bin/expect --
set timeout 600
stty -echo
log_user 0
spawn -noecho sudo -u introot /home/introot/bin/twssh
expect root
send_user "Entering \r"
send "uname\r"... (15 Replies)
Hi,
Im programming an interactive menu that verifies the exports of my oracle DB, and im having some trouble finding a process that outputs for example a green command line when the export terminated successfully. i have something like this
cat... (15 Replies)
Hi,
Am trying to store the user inputs into a file, but the below code will store only the first line of the values. I need to store all the user input values which may contain one or more lines. Thanks in advance.
echo "please enter file names";
read name;
echo $name>/tmp/test (11 Replies)
Hi,
GetName()
{
if
then
echo " Please enter the name: "
read Name
tempvar=0
while read line
do
if
then
tempvar=`expr $tempvar + 1`
echo $tempvar
... (10 Replies)
Hi all,
I have a script which should take more than 9 command line inputs while running. Likescript.sh a s d f g h j j k l o p i u y t r e w
Now in the script if I have to access one of the input which is at position after 9, in this case say 'p' then how can I do that?
echo $12 will not work... (15 Replies)
Hi All,
I am writing a shell script.
#!/bin/bash
cat /etc/hosts
mkdir -p /var/tmp
mount 113.123.35.37:/vol/vol615/syb /var/tmp
In above script I am trying to add below predefined script/command (/var/tmp/db_tools)
This command in turn ask for user input, which will be always option... (17 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)