USERCONF(4) BSD Kernel Interfaces Manual USERCONF(4)NAME
userconf -- in-kernel device configuration manager
userconf is the in-kernel device configuration manager. It is used to alter the kernel autoconfiguration framework at runtime. userconf is
activated from the boot loader by passing the -c option to the kernel.
The general command syntax is:
userconf has a more(1)-like functionality; if a number of lines in a command's output exceeds the number defined in the lines variable, then
userconf displays ``-- more --'' and waits for a response, which may be one of:
<return> one more line.
<space> one more page.
q abort the current command, and return to the command input mode.
userconf supports the following commands:
Specify the number of lines before more.
base 8 | 10 | 16
Base for displaying large numbers.
change devno | dev
disable devno | dev
enable devno | dev
exit A synonym for quit.
find devno | dev
help Display online help.
list List current configuration.
quit Leave userconf.
? A synonym for help.
The userconf framework first appeared in OpenBSD 2.0, and was then integrated into NetBSD 1.6.
The userconf framework was written by Mats O Jansson <firstname.lastname@example.org>.
BSD July 1, 2001 BSD
Check Out this Related Man Page
SND_UAUDIO(4) BSD Kernel Interfaces Manual SND_UAUDIO(4)NAME
snd_uaudio -- USB audio and MIDI device driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The snd_uaudio driver provides support for USB audio class devices and USB MIDI class devices.
A USB audio device consists of a number of components: input terminals (e.g. USB digital input), output terminals (e.g. speakers), and a num-
ber of units in between (e.g. volume control).
Refer to the 'USB Audio Class Specification' for more information.
SEE ALSO sound(4), usb(4)
USB Audio Class Specifications, http://www.usb.org/developers/devclass_docs/.
The snd_uaudio driver first appeared in FreeBSD 4.7.
This manual page was adopted from NetBSD 1.6 and modified for FreeBSD by Hiten Pandya <hmp@FreeBSD.org>.
The PCM framework in FreeBSD, as of this writing, does not handle device un-registrations in a properly abstracted manner, i.e., a detach
request is refused by the PCM framework if the device is in use. It is necessary to allow the device un-registration to complete success-
fully, otherwise the PCM layer will panic.
BSD February 24, 2011 BSD
while setting up the Horde framework on OpenBSD 3.0, I discovered the following error:
configure: error: Cannot find rfc822.h. Please check your IMAP installation.
*** Error code 1
Stop in /usr/ports/www/php4 (line 1703 of /usr/ports/infrastructure/mk/bsd.port.mk).
***... (1 Reply)
I have a doubt when using WC commnad along with file name, it is displaying information on the same line like number of lines in that file ,number of words ,number of characters and finally name of the file we are currently viewing. i dont want to display the filename at... (4 Replies)