Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ukyopon(4) [netbsd man page]

UKYOPON(4)						   BSD Kernel Interfaces Manual 						UKYOPON(4)

NAME
ukyopon -- Kyocera AIR-EDGE PHONE support SYNOPSIS
ukyopon* at uhub? ucom* at ukyopon? portno ? #include <dev/usb/ukyopon.h> DESCRIPTION
The ukyopon driver provides support for Kyocera AIR-EDGE PHONE AH-K3001V. Two units of this driver attach to an AIR-EDGE PHONE: the modem port and the data transfer port. The modem port is compatible to umodem(4), and can be used for dialup connections. The data transfer port is for reading and writing internal storage of AIR-EDGE PHONE. Both devices are accessed through the ucom(4) driver which makes them behave like a tty(4). The manipulation of the internal storage is through external programs, for example, the pkgsrc/comms/kyopon package. IOCTLS
The following ioctl(2) calls apply to the ukyopon device: UKYOPON_IDENTIFY struct ukyopon_identify Read, from the kernel, the identification information of the device, useful to assure that the opened device node is a modem or a data transfer port of ukyopon device. struct ukyopon_identify { char ui_name[16]; /* driver name */ int ui_busno; /* usb bus number */ uint8_t ui_address; /* device address */ enum ukyopon_model { UKYOPON_MODEL_UNKNOWN } ui_model; /* possibly future use */ enum ukyopon_port { UKYOPON_PORT_UNKNOWN, UKYOPON_PORT_MODEM, /* modem port */ UKYOPON_PORT_DATA /* data transfer port */ } ui_porttype; /* port type */ int ui_rsvd1, ui_rsvd2; }; #define UKYOPON_NAME "ukyopon" The ui_name field contains the driver signature, and has the string UKYOPON_NAME. The ui_busno field contains the usb(4) bus number to which the device is connected; the ui_address field contains the address of the device in the bus. These fields are useful to identify the physical device from the file descriptor. The ui_porttype field contains the type of device: UKYOPON_PORT_MODEM means the device is associated to the modem port, and UKYOPON_PORT_DATA means the device is associated to the data transfer port. Other fields are reserved for future extension and cleared to zeros. In addition, ukyopon devices accept all ioctl(2) calls that umodem(4) accepts. SEE ALSO
tty(4), ucom(4), umodem(4), usb(4), pkgsrc/comms/kyopon HISTORY
The ukyopon driver appeared in NetBSD 3.0. NOTES
``Kyopon'' is a widely-used nickname of Kyocera AIR-EDGE PHONE. BSD
May 18, 2005 BSD

Check Out this Related Man Page

UFOMA(4)						   BSD Kernel Interfaces Manual 						  UFOMA(4)

NAME
ufoma -- USB mobile phone support SYNOPSIS
To compile this driver into the kernel, place the following lines in your kernel configuration file: device ufoma device ucom Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): ufoma_load="YES" DESCRIPTION
The ufoma driver provides support for USB mobile phone terminals in the subset of the Mobile Computing Promotion Consortium USB Implementa- tion Guideline, which is adopted by FOMA, the NTT DoCoMo 3G system, terminal. These are partly like CDC ACM model based modems, which are supported by umodem(4), but the ufoma driver recognizes a specific USB descriptor that describes its role and interface structure, and it will negotiate its role when the device is open. They support a regular AT command set and the commands can either be multiplexed with the data stream or handled through separate pipes. In the latter case the AT commands have to be given on a device separate from the data device. The device is accessed through the ucom(4) driver which makes it behave like a tty(4). SYSCTLS
These devices often have a few interface sets and these interfaces have their role, sometimes multiplexed. These roles are identified with the following sysctl MIBs: dev.ucom.%d.supportmode The modes which are supported by the interface. dev.ucom.%d.currentmode Current mode of the interface. dev.ucom.%d.openmode Mode to transit when the device is open next. The modes are as follows: modem Accepts AT commands and go and pass packet communication data. handsfree Accepts AT commands but it does not pass data. obex Accepts OBEX frame which is used to exchange telephone book, etc. vendor1, vendor2 Vendor specific data may be passed. deactivated When an interface is recognized by the system but not used, the interface will be set to this mode. unlinked When an interface is not yet negotiated, the interface is in this mode. HARDWARE
Devices supported by the ufoma driver include: o SHARP FOMA SH902i o KYOCERA PHS AH-K3001V (a.k.a Kyopon) o SANYO Vodafone3G V801SA SEE ALSO
Specification can be found at: http://www.nttdocomo.co.jp/corporate/technology/document/foma/index.html http://www.mcpc-jp.org/doclist.htm tty(4), ucom(4), umodem(4), usb(4) HISTORY
The ufoma driver appeared in FreeBSD 7.0, partly derived from the umodem(4) code. BUGS
Interfaces with multiplexed commands and data and interfaces with commands only are supported. BSD
November 22, 2006 BSD
Man Page