UDP(4) BSD Kernel Interfaces Manual UDP(4)
udp -- Internet User Datagram Protocol
socket(AF_INET, SOCK_DGRAM, 0);
socket(AF_INET6, SOCK_DGRAM, 0);
UDP is a simple, unreliable datagram protocol which is used to support the SOCK_DGRAM abstraction for the Internet protocol family. UDP
sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) calls, though the connect(2) call may also be used to
fix the destination for future packets (in which case the recv(2) or read(2) and send(2) or write(2) system calls may be used).
UDP address formats are identical to those used by TCP. In particular UDP provides a port identifier in addition to the normal Internet
address format. Note that the UDP port space is separate from the TCP port space (i.e. a UDP port may not be ``connected'' to a TCP port).
In addition broadcast packets may be sent (assuming the underlying network supports this) by using a reserved ``broadcast address''; this
address is network interface dependent.
There are two UDP-level setsockopt(2)/getsockopt(2) options. UDP_OPTIONS may be used to change the default behavior of the socket. For
setsockopt(s, IPPROTO_UDP, UDP_OPTIONS, NULL, 0);
The UDP_ENCAP option can be used to encapsulate ESP packets in UDP. There are two valid enapsulation options: UDP_ENCAP_ESPINUDP_NON_IKE
from draft-ietf-ipsec-nat-t-ike-00/01 and UDP_ENCAP_ESPINUDP from draft-ietf-ipsec-udp-encaps-06 defined in <netinet/udp.h>.
The UDP_RFC6056ALGO can be used to randomize the port selection. Valid algorithms are described in rfc6056(7) and their respective constants
are in <netinet/rfc6056.h>. For example,
int algo = RFC6056_ALGO_RANDOM_PICK; /* see <netinet/rfc6056.h> */
setsockopt(s, IPPROTO_UDP, UDP_RFC6056ALGO, &algo, sizeof(algo));
The port selection can be also controlled at a global level for all UDP or UDP6 sockets using the following sysctl(7) variables:
net.inet.udp.rfc6056.selected and net.inet6.udp6.rfc6056.selected respectively.
Options at the IP transport level may be used with UDP; see ip(4) or ip6(4).
A socket operation may fail with one of the following errors returned:
[EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destina-
tion address specified and the socket is already connected;
[ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been connected;
[ENOBUFS] when the system runs out of memory for an internal data structure;
[EADDRINUSE] when an attempt is made to create a socket with a port which has already been allocated;
[EADDRNOTAVAIL] when an attempt is made to create a socket with a network address for which no network interface exists.
getsockopt(2), recv(2), send(2), socket(2), inet(4), inet6(4), intro(4), ip(4), ip6(4), rfc6056(7), sysctl(7)
User Datagram Protocol, RFC, 768, August 28, 1980.
Requirements for Internet Hosts -- Communication Layers, RFC, 1122, October 1989.
The udp protocol appeared in 4.2BSD.
September 24, 2011 BSD