|Linux & Unix Commands - Search Man Pages
U3G(4) BSD Kernel Interfaces Manual U3G(4)
u3g -- USB support for 3G datacards
To compile this driver into the kernel, place the following lines in your kernel configura-
u3ginit* at uhub? port ?
u3g* at uhub? port ?
ucom* at u3g?
The u3g driver provides support for the multiple USB-to-serial interfaces exposed by many 3G
USB/PC Card modems.
The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
The u3g driver supports the following adapters:
o Huawei E220 (E270?)
o Huawei Mobile
o Novatel MC950D
o Option Globetrotter 3G
o Option Globetrotter 3G Fusion (only 3G part, not WLAN)
o Option Globetrotter 3G Fusion Quad (only 3G part, not WLAN)
o Option Globetrotter 3G Quad
o Vodafone Mobile Connect Card 3G
The supported 3G cards provide the necessary modem port for ppp, pppd, or mpd connections as
well as extra ports (depending on the specific device) to provide other functions (diagnos-
tic port, SIM toolkit port).
tty(4), ubsa(4), ucom(4), usb(4)
The u3g driver appeared in NetBSD 5.0. The ubsa(4) manual page was modified for u3g by
Andrea Guzzo <firstname.lastname@example.org> in September 2008.
The u3g driver was written by Andrea Guzzo <email@example.com>. Hardware for testing pro-
vided by AnyWi Technologies, Leiden, NL.
BSD June 28, 2010 BSD
All times are GMT -4. The time now is 09:47 PM.