|Linux & Unix Commands - Search Man Pages
STUIRDA(4) BSD Kernel Interfaces Manual STUIRDA(4)
stuirda -- Sigmaltel 4116/4220 USB-IrDA bridge support
stuirda* at uhub?
irframe* at uirda?
The stuirda driver provides support for SigmaTels USB-IrDA bridges that nearly follow the
Access to the IrDA device is through the irframe(4) driver. Before accessing it, a firmware
patch must be downloaded. At the time of writing this, it can be found at:
Unpack the archive with
tar -C /libdata/firmware/stuirda/ -xzf stir4210_4220_4116_patch_files.tar.gz
The stuirda driver appeared in NetBSD 5.0.
stuirda needs the firmware for configuration, so it can't be loaded at kernel startup time.
As a workaround, you can plug in the USB-IrDA-bridge after booting.
BSD October 13, 2008 BSD
All times are GMT -4. The time now is 03:27 AM.