STUIRDA(4) BSD Kernel Interfaces Manual STUIRDA(4)NAME
stuirda -- Sigmaltel 4116/4220 USB-IrDA bridge support
stuirda* at uhub?
irframe* at uirda?
The stuirda driver provides support for SigmaTels USB-IrDA bridges that nearly follow the bridge specification:
Access to the IrDA device is through the irframe(4) driver. Before accessing it, a firmware patch must be downloaded. At the time of writ-
ing this, it can be found at: http://www.sigmatel.com/documents/stir4210_4220_4116_patch_files.tar.gz
Unpack the archive with
tar -C /libdata/firmware/stuirda/ -xzf stir4210_4220_4116_patch_files.tar.gz
SEE ALSO irframe(4), usb(4)HISTORY
The stuirda driver appeared in NetBSD 5.0.
stuirda needs the firmware for configuration, so it can't be loaded at kernel startup time. As a workaround, you can plug in the USB-IrDA-
bridge after booting.
BSD October 13, 2008 BSD
Check Out this Related Man Page
IRFRAME(4) BSD Kernel Interfaces Manual IRFRAME(4)NAME
irframe -- IrDA frame level driver
irframe* at oboe?
irframe* at uirda?
irframe* at ustir?
The irframe driver provides support for IrDA frame level transmission. It does not contain the IrDA protocol stack per se, but the stack can
be built on top of the irframe driver.
Access to frames is via the read(2) and write(2) system calls. Each write constitutes one frame, and each read yields one frame. The
poll(2) system call can be used to check for availability of frames. There are also a number of ioctl(2) calls to manipulate the device:
Reset the parameters set by IRDA_SET_PARAMS.
IRDA_SET_PARAMS (struct irda_params)
Set the speed, extra beginning of frame bytes, and maximum frame size.
Get the set of allowable speeds.
Get the set of allowable turn around times.
SEE ALSO cir(4), irframetty(4), oboe(4), uirda(4), ustir(4)
The irframe driver appeared in NetBSD 1.6.
BSD December 2, 2001 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)