SIOP(4) BSD Kernel Interfaces Manual SIOP(4)NAME
siop -- Symbios Logic/NCR 53c8xx SCSI driver
siop* at mainbus? irq 3
siop* at phatomas? irq 3
siop* at pci? dev ? function ?
scsibus* at siop?
The siop driver provides support for the Symbios Logic/NCR 53x8xx series of SCSI controller chips:
- 53c810, 53c810a and 53c815 (Fast SCSI)
- 53c820, 53c825 and 53c825a (Fast-Wide SCSI)
- 53c860 (Ultra SCSI)
- 53c875 and 53c875j (Ultra-Wide SCSI)
- 53c876 (Dual Ultra-Wide SCSI)
- 53c885 (Ultra-Wide SCSI and Ethernet)
- 53c895 (Ultra2-Wide SCSI)
- 53c896 (PCI 64bit, dual Ultra2-Wide SCSI)
- 53c1010-33 (PCI 64bit, dual Ultra160 SCSI)
- 53c1510d (PCI 64bit, dual Ultra2-wide SCSI)
The SIOP_SYMLED option causes the driver to report SCSI activity on the GPIO pin 1, which is connected to the activity LED on some adapters.
At this time only the 53c895 based Symbios and Tekram adapters are known to require this.
If both siop and the esiop(4) drivers are compiled, esiop(4) will take precedence for controllers it supports.
SEE ALSO cd(4), ch(4), esiop(4), intro(4), pci(4), scsi(4), sd(4), st(4), uk(4)HISTORY
The siop driver first appeared in NetBSD 1.5.
The siop driver was written by Manuel Bouyer <Manuel.Bouyer@lip6.fr> for NetBSD.
siop supports the 53c1010-33 in Ultra2-wide mode only. Use esiop(4) for Ultra160 support.
BSD April 5, 2008 BSD
Check Out this Related Man Page
ADV(4) BSD Kernel Interfaces Manual ADV(4)NAME
adv -- ConnectCom Solutions AdvanSys SCSI adapter driver
adv* at pci? dev ? function ?
adv0 at isa? port ? irq ? drq ?
adv* at cardbus? function ?
scsibus* at adv?
The adv driver supports the following AdvanSys SCSI host adapters
ABP920 Bus-Master PCI (16 CDB)
ABP930 Bus-Master PCI (16 CDB) (note 1)
ABP930U Bus-Master PCI Ultra (16 CDB)
ABP930UA Bus-Master PCI Ultra (16 CDB)
ABP960 Bus-Master PCI MAC/PC (16 CDB) (note 2)
ABP960U Bus-Master PCI MAC/PC Ultra (16 CDB) (note 2)
1. This board has been sold by SIIG as the Fast SCSI Pro PCI.
2. This board has been sold by Iomega as a Jaz Jet PCI adapter.
Single Channel Products:
ABP940 Bus-Master PCI (240 CDB)
ABP940U Bus-Master PCI Ultra (240 CDB)
ABP970 Bus-Master PCI MAC/PC (240 CDB)
ABP970U Bus-Master PCI MAC/PC Ultra (240 CDB)
ABP940UW Bus-Master PCI Ultra-Wide (240 CDB)
Multi Channel Products:
ABP950 Dual Channel Bus-Master PCI (240 CDB Per Channel)
ABP980 Four Channel Bus-Master PCI (240 CDB Per Channel)
ABP980U Four Channel Bus-Master PCI Ultra (240 CDB Per Channel)
ABP510/5150 Bus-Master ISA (240 CDB) (note 1)
ABP5140 Bus-Master ISA (16 CDB) (note 1) (note 2)
ABP5142 Bus-Master ISA with floppy (16 CDB) (note 3)
1. This board has been shipped by HP with the 4020i CD-R drive. The board has no BIOS so it cannot control a boot device, but it can con-
trol any secondary SCSI device.
2. This board has been sold by SIIG as the i540 SpeedMaster.
3. This board has been sold by SIIG as the i542 SpeedMaster.
Single Channel Products:
ABP542 Bus-Master ISA with floppy (240 CDB)
ABP842 Bus-Master VL (240 CDB)
Dual Channel Products:
ABP852 Dual Channel Bus-Master VL (240 CDB Per Channel)
SEE ALSO cd(4), ch(4), intro(4), isa(4), pci(4), scsi(4), sd(4), st(4)
The adv device driver appeared in NetBSD 1.4.
Baldassare Dante Profeta <email@example.com>
BSD June 4, 1999 BSD
Hi. I need to find a simple SCSI adapter card for a Sun Ultra 5 workstation. I don't need the type w/ ethernet attached (e.g. X1032) as I already have ethernet onboard & they are more spendy.
I know Adaptec is out, but what unit would work? I am attaching an external SCSI tape unit to this... (4 Replies)
I seem to be having a driver issue installing a PCI SCSI card. Any ideas where I can track these down.. I can't seem to find them on the OS install disk. I'm using AIX 5.3.
cfgmgr: 0514-621 WARNING: The following device packages are required for
device support but are not currently... (7 Replies)
I have 1 PCI-X Dual Channel Ultra320 SCSI Adapter card for my p570 server. I would like to split the 2 channels for the usage of 2 tape drives in different LPARs. Is that possible?
For example, I have 2 LPARs running in p570 server, LPAR-A configured the Ultra320 card as pci7 in slot... (11 Replies)
I have googled and checked this forum in detail and couldn't find any satisfactory answers for my problem.
I am trying to connect a external SCSI hard Drive(Sea Gate) to a Ultra 80.
I connected it powered it up and at OK prompt did : boot -r
system comes up and complains about not... (6 Replies)
I have an IBM AIX 5.3 64Bit running with 64bit application (Kernel runs on 64bit also).
I changed the maximum proccesses per user to the maximum.
Currently the pids of proccesses in the system using 5 digits (<100000).
Is it possible to make the system use pids bigger then 4500000? I need it... (6 Replies)
I need to check whether the compiler installed in my system supports 64bit compilation.
Server - Sun fire v490
OS - Solaris 5.9
Processor - Sparcv9 (64bit)
Install Directory - /opt/SUNWSpro
Compiler Model - Sun Forte C Compiler.
My development team is claiming that there... (20 Replies)
Have been learning a lot off late and am a little unclear about the VIOS setup particularly with regards to redundancy. Would appreciate your help.
My question is very basic. Lets say I have setup a VIOS and 3 LPARs on only one hdd (non scsi). On what do I setup the second VIOS? Could I for... (7 Replies)
I have a Sun Ultra 45 that was working perfectly until i upgraded it to Update 9 with a zfs filesystem. The box is sparc based and has an internal video card. When i boot it up, i receive an X server error and, while checking /var/dt/Xerrors, the following message is displayed
Fatal server... (9 Replies)
I am new to this forum as well as to the UNIX world. Recently graduated with a degree in Computing and just started learning UNIX & bought 3 Sun Ultra 10 Servers. I was trying to set the Servers up so I can use them; the Servers don't have a VGA card. My laptop, which I would be... (6 Replies)
Last year, after registering on Sun support site, I downloaded for free all available documentation (in PDF) and support files of a couple of old Sun workstations (Ultra 5 and Ultra 10).
Now I need the documentation and support files of other old Sun workstations (SPARCstation 20 and... (4 Replies)
So my family is cleaning out our house and my dad stumbled on a Unix system with Unigraphix installed on it, and he remembers that it was 1 of 6 computers in a set that he used at a tool and dye machine shop where he worked. He said that the computer by itself with the monitor was $20,000! I was... (8 Replies)
I just got moved to a new office building, and as I was unpacking my stuff I saw an odd tower PC in the nearby recycling heap. It turned out to be a Sun Ultra 10 Elite3D workstation, complete with keyboard, mouse, and monster-sized CRT with the wacky Sun video cable.
I just set everything up and... (4 Replies)
I have just acquired an Ultra 5. It has 256MB of memory and a 360Mhz Ultra IIi SPARC processor. So far, I have had some typical fun and games to get it working:
- It had a dead NVRAM chip. I hacked it open and installed a CR2032. It looks suitably bodged up, but is working. I set the MAC... (8 Replies)