SGSMIX(4) BSD Kernel Interfaces Manual SGSMIX(4)NAME
sgsmix -- driver for SGS 7433 Basic Audio Processor found in some Apple machines
SYNOPSIS
iic* at cuda?
sgsmix* at iic? addr 0x8a
DESCRIPTION
The sgsmix driver provides support for the external mixer chip on Apple's ``personality cards'' found in beige Power Macintosh G3. All mixer
controls are accessed through the awacs(4) driver, sgsmix additionally provides bass and treble controls.
SEE ALSO awacs(4), cuda(4), iic(4)BSD May 14, 2007 BSD
Check Out this Related Man Page
IIC(4) BSD Kernel Interfaces Manual IIC(4)NAME
iic -- Inter IC (I2C) bus
SYNOPSIS
iic* at alipm? # sparc64
iic* at acpismbus? # amd64 i386
iic* at amdpm? # amd64 i386
iic* at armadillo9iic? # evbarm
iic0 at at91twi? # evbarm
iic0 at ausmbus0 # evbmips
iic0 at cuda0 # macppc
iic0 at gpiic? # evbppc
iic* at gpioiic? # amd64 i386
iic* at gtiic? # evbppc
iic* at gxiic? # evbarm
iic* at ichsmb? # amd64 i386
iic0 at iociic0 # acorn26
iic0 at iomdiic? # acorn32
iic0 at iopiic? # evbarm iyonix
iic* at ki2c? # macppc
iic* at nfsmb? # amd64 i386
iic* at ociic? # sandpoint
iic* at piixpm? # amd64 i386
iic0 at slugiic0 # evbarm
iic* at viapcib? # i386
DESCRIPTION
I2C is a two-wire bus developed by Philips used for connecting integrated circuits. It is commonly used for connecting devices such as EEP-
ROMs, temperature sensors, fan controllers, real-time clocks, tuners, and other types of integrated circuits.
The iic driver provides a uniform programming interface layer between I2C master controllers and various I2C slave devices. Each I2C master
controller attaches an iic framework; several slave devices can then be attached to the iic bus.
All I2C slave devices are uniquely identified by the address on the bus. The master accesses a particular slave device using its address.
System Management Bus (SMBus) protocol is also supported by emulating it with the I2C commands.
SUPPORTED MASTERS
A wide list of I2C masters are supported, among them are:
alipm(4) Acer Labs M7101 SMBus controller
acpismbus(4) ACPI SMBus Control Method Interface
amdpm(4) AMD768 Power Management Controller and AMD8111 System Management Controller
armadillo9iic(4)at91twi(4)ausmbus(4)cuda(4) support for CUDA microcontrollers found in many Power Macintosh and and compatible computers
gpiic(4)gtiic(4)gxiic(4)ichsmb(4) Intel ICH SMBus controller
iociic(4)iomdiic(4)iopiic(4)ki2c(4)gpioiic(4) GPIO bit-banging
nfsmb(4) NVIDIA nForce 2/3/4 SMBus controller and SMBus driver
ociic(4)piixpm(4) Intel PIIX and compatible Power Management controller
slugiic(4)viapcib(4)SUPPORTED SLAVES
A wide list of slaves are supported, among them:
dbcool(4) dbCool(tm) family of environmental monitors and fan controllers
rs5c372rtc(4) RICOH RS5C372A and RS5C372B real-time clock
sgsmix(4) driver for SGS 7433 Basic Audio Processor found in some Apple machines
spdmem(4) Generic Memory Module Serial Presence Detect
SEE ALSO dtviic(4), intro(4), i2cscan(8), iic(9)HISTORY
The I2C framework first appeared in NetBSD 2.0. OpenBSD support was added in OpenBSD 3.6. This manpage first appeared in NetBSD 6.0, it was
ported from OpenBSD.
AUTHORS
The I2C framework was written by Steve C. Woodford and Jason R. Thorpe for NetBSD and then ported to OpenBSD by Alexander Yurchenko
<grange@openbsd.org>.
BSD October 15, 2011 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)