netbsd man page for pud

Query: pud

OS: netbsd

Section: 4

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PUD(4)							   BSD Kernel Interfaces Manual 						    PUD(4)

NAME
pud -- Pass-to-Userspace Device
SYNOPSIS
pseudo-device pud pseudo-device putter
DESCRIPTION
The pud driver enables the implementation of block and character device drivers as userspace daemons. The daemons register the device major number they wish to handle. Registering a character device is mandatory, supporting the block device interface for same major device is optional. The major number must be available, i.e. another driver must not be registered to handle the operation. After successful regis- tration the userspace daemon is supposed to handle the driver methods the kernel passes down to it.
SEE ALSO
puffs(4), putter(9)
BUGS
This document is in a hit-in-the-head style obviously not even near complete. The subsystem lacks a puffs-style library that servers can be written against.
BSD
November 21, 2007 BSD
Related Man Pages
rump_nfs(8) - netbsd
rump_smbfs(8) - netbsd
clone(7) - hpux
pty(4) - php
pty(4) - posix
Similar Topics in the Unix Linux Community
Development Release: xPUD 0.8
Distribution Release: xPUD 0.8.9
Distribution Release: xPUD 0.9
Reminder for ripudaman.singh: Bumping Up Posts
Reminder for BHASKAR JUPUDI: 1st Reminder to Add Code Tags