NSCLPCSIO(4) BSD Kernel Interfaces Manual NSCLPCSIO(4)NAME
nsclpcsio -- National Semiconductor PC87366 LPC Super I/O
nsclpcsio* at isa?
gpio* at nsclpcsio?
The nsclpcsio driver provides support for the National Semiconductor PC87366 LPC Super I/O. The Super I/O incorporates several logical
devices, the following ones are supported: GPIO, VLM and TMS.
The GPIO logical device provides 29 I/O pins which can be accessed through the gpio(4) framework. The gpioctl(8) program allows easy manipu-
lation of the pins from userland.
VLM and TMS logical devices provides hardware monitoring capabilities to be used with the envsys(4) API. The following 17 monitoring sensors
Sensor Units Typical Use
TSENS1 uK Remote diode
TSENS2 uK Remote diode
TNSC uK Local diode
VSENS0 uV DC External source
VSENS1 uV DC External source
VSENS2 uV DC External source
VSENS3 uV DC External source
VSENS4 uV DC External source
VSENS5 uV DC External source
VSENS6 uV DC External source
VSB uV DC VSB
VDD uV DC VDD
VBAT uV DC VBAT
AVDD uV DC AVDD
TS1 uV DC Thermistor
TS2 uV DC Thermistor
TS3 uV DC Thermistor
SEE ALSO envsys(4), envstat(8)HISTORY
The nsclpcsio device appeared in NetBSD 2.0.
The chip decodes address ranges which are not obvious and cannot be controlled by the kernel configuration file (must be set up by the BIOS).
BSD November 9, 2007 BSD
Check Out this Related Man Page
GPIOLOCK(4) BSD Kernel Interfaces Manual GPIOLOCK(4)NAME
gpiolock -- support for multi-position keylocks attached to GPIO pins
gpiolock* at gpio? offset ? mask ?
gpiolock* at gpio?
The gpiolock driver allows connecting of multi-position keylocks over GPIO pins. The keylock driver registers with an in-kernel keylock sup-
porting system and provides kauth(9) support through an experimental security model. The keylock state can be queried using the hw.keylock
sysctl variables. Only locks with 2-4 positions are currently supported. The pin number is specified in the kernel configuration with the
offset locator. The mask locator denotes the pins used for the lock (minimum 2, maximum 4 pins are used). The offset and mask can also be
specified when gpiolock is attached at runtime using the GPIOATTACH ioctl(2) on the gpio(4) device.
SEE ALSO gpio(4), intro(4)HISTORY
The gpiolock driver first appeared in NetBSD 6.0.
The gpiolock driver was written by Marc Balmer <firstname.lastname@example.org>.
BSD August 21, 2009 BSD
When they say that the G5 is the faster (more faster) than any UNIX Workstation that means Dual Processor Workstations right?
(Stupid Question, I know)
I heard theres one Super Super clusternode in a research and varsity joint in the US that will have over 1200 G5's chips in it?
Medical,... (2 Replies)
I'm now studying as junior student in VSB-TUO university in Czech Republic. My teacher give me some tasks about sh programming. he always ask about : to access file, del sime string in this...or access system like count sum of files and count how many files in this address... or talk this people... (2 Replies)
National Healthcare Will Require National RFID Chips
@Neo you're right, here i go with some personal comments about this :
In my opinion, i am quite happy that such a thing doesn't currently happen in my country ... but it doesn't mean i am confident in the futur.
What worry me is that those... (12 Replies)
I was recently working on a project where some gpio pins were being toggled from within the user space:
const char *const amplifierGPIO = "/sys/class/gpio/gpio107/value";
... (3 Replies)