MHZC(4) BSD Kernel Interfaces Manual MHZC(4)NAME
mhzc -- Megahertz Ethernet/modem card driver
SYNOPSIS
mhzc* at pcmcia? function ?
com* at mhzc?
sm* at mhzc?
DESCRIPTION
The mhzc device driver provides support for the Megahertz combined Ethernet and modem cards.
SEE ALSO com(4), pcmcia(4), sm(4)HISTORY
The mhzc driver appeared in NetBSD 1.5.
BSD February 18, 2007 BSD
Check Out this Related Man Page
COM(4) BSD Kernel Interfaces Manual COM(4)NAME
com -- serial communications interface for RS-232C
SYNOPSIS
com0 at isa? port "IO_COM1" irq 4
com1 at isa? port "IO_COM2" irq 3
com* at acpi?
com* at cardbus?
com* at isapnp?
com* at mca? slot ?
com* at mhzc?
com* at ofisa?
com* at pcmcia?
com* at pcmcom?
com* at pnpbios? index ?
com* at puc? port ?
com* at xirc?
options COM_HAYESP
options PPS_SYNC
options PPS_TRAILING_EDGE
options RND_COM
Arm32
com0 at mainbus? base 0x00210fe0
com1 at mainbus? base 0x00210be0
HP 9000/300 and 400 Series
com* at dio? scode ?
com* at frodo? offset ?
HP 9000/700 and 800 Series
com* at dino?
com* at gsc?
com* at ssio?
IBM PowerPC 4xx
com* at opb?
SPARC
com* at ebus?
com* at obio0
DESCRIPTION
The com driver provides support for NS8250-, NS16450-, and NS16550-based EIA RS-232C (CCITT V.28) communications interfaces. The NS8250 and
NS16450 have single character buffers, and the NS16550 has a 16 character buffer.
Input and output for each line may set to one of following baud rates; 50, 75, 110, 134.5, 150, 300, 600, 1200, 1800, 2400, 4800, 9600,
19200, 38400, 57600, or 115200, or any other baud rate which is a factor of 115200.
The ttyXX devices are traditional dial-in devices; the dtyXX devices are used for dial-out. (See tty(4).)
options COM_HAYESP adds support for the Hayes ESP serial board.
options PPS_SYNC enables code to use the Data Carrier Detect (DCD) signal line for attachment to an external precision clock source (e.g.,
GPS, CDMA) which generates a Pulse Per Second (PPS) signal. This is used by ntpd(8) to discipline the system clock, and more accurately
count/measure time. See options(4) for more discussion.
With options RND_COM enabled, the com driver can be used to collect entropy for the rnd(4) entropy pool. The entropy is generated from
interrupt randomness.
Arm32 specific
If ``flags 1'' is specified, the com driver will not set the MCR_IENABLE bit on the UART. This is mainly for use on AST multiport boards,
where the MCR_IENABLE bit is used to control whether or not the devices use a shared interrupt.
FILES
/dev/dty00
/dev/dty01
/dev/dty02
/dev/tty00
/dev/tty01
/dev/tty02
DIAGNOSTICS
com%d: %d silo overflows The input ``silo'' has overflowed and incoming data has been lost.
com%d: weird interrupt: iir=%x The device has generated an unexpected interrupt with the code listed.
SEE ALSO acpi(4), ast(4), cardbus(4), isa(4), isapnp(4), mca(4), mhzc(4), ofisa(4), options(4), pcmcia(4), pcmcom(4), pnpbios(4), puc(4), rtfps(4),
tty(4), xirc(4), ntpd(8)HISTORY
The com driver was originally derived from the HP9000/300 dca driver.
BUGS
Data loss is possible on busy systems with unbuffered UARTs at high speed.
The name of this driver and the constants which define the locations of the various serial ports are holdovers from DOS.
BSD June 7, 2011 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)