Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

iso(4) [netbsd man page]

ISO(4)							   BSD Kernel Interfaces Manual 						    ISO(4)

NAME
iso -- ISO protocol family SYNOPSIS
#include <sys/types.h> #include <netiso/iso.h> DESCRIPTION
The ISO protocol family is a collection of protocols that uses the ISO address format. The ISO family provides protocol support for the SOCK_SEQPACKET abstraction through the TP protocol (ISO 8073), for the SOCK_DGRAM abstraction through the connectionless transport protocol (ISO 8602), and for the SOCK_RAW abstraction by providing direct access (for debugging) to the CLNP (ISO 8473) network layer protocol. ADDRESSING
ISO addresses are based upon ISO 8348/AD2, Addendum to the Network Service Definition Covering Network Layer Addressing. Sockets bound to the OSI protocol family use the following address structure: struct iso_addr { u_char isoa_len; /* length, not including this byte */ char isoa_genaddr[20]; /* general opaque address */ }; struct sockaddr_iso { u_char siso_len; /* size of this sockaddr */ sa_family_t siso_family; /* addressing domain, AF_ISO */ u_char siso_plen; /* presentation selector length */ u_char siso_slen; /* session selector length */ u_char siso_tlen; /* transport selector length */ struct iso_addr siso_addr; /* network address */ u_char siso_pad[6]; /* space for gosip v2 SELs */ }; #define siso_nlen siso_addr.isoa_len #define siso_data siso_addr.isoa_genaddr The fields of this structure are: siso_len: Length of the entire address structure, in bytes, which may grow to be longer than the 32 bytes shown above. siso_family: Identifies the domain: AF_ISO. siso_tlen: Length of the transport selector. siso_slen: Length of the session selector. This is not currently supported by the kernel and is provided as a convenience for user level pro- grams. siso_plen: Length of the presentation selector. This is not currently supported by the kernel and is provided as a convenience for user level programs. siso_addr: The network part of the address, described below. TRANSPORT ADDRESSING
An ISO transport address is similar to an Internet address in that it contains a network-address portion and a portion that the transport layer uses to multiplex its services among clients. In the Internet domain, this portion of the address is called a port. In the ISO domain, this is called a transport selector (also known at one time as a transport suffix). While ports are always 16 bits, transport selec- tors may be of (almost) arbitrary size. Since the C language does not provide convenient variable length structures, we have separated the selector lengths from the data themselves. The network address and various selectors are stored contiguously, with the network address first, then the transport selector, and so on. Thus, if you had a network address of less than 20 bytes, the transport selector would encroach on space normally reserved for the network address. NETWORK ADDRESSING
ISO network addresses are limited to 20 bytes in length. ISO network addresses can take any format. PROTOCOLS
The ARGO 1.0 implementation of the ISO protocol family comprises the Connectionless-Mode Network Protocol (CLNP), and the Transport Protocol (TP), classes 4 and 0, and X.25. TP is used to support the SOCK_SEQPACKET abstraction. A raw interface to CLNP is available by creating an ISO socket of type SOCK_RAW. This is used for CLNP debugging only. SEE ALSO
clnp(4), cltp(4), tp(4) BSD
November 30, 1993 BSD

Check Out this Related Man Page

INET(4) 						   BSD Kernel Interfaces Manual 						   INET(4)

NAME
inet -- Internet protocol family SYNOPSIS
#include <sys/types.h> #include <netinet/in.h> DESCRIPTION
The Internet protocol family is a collection of protocols layered atop the Internet Protocol (IP) transport layer, and utilizing the Internet address format. The Internet family provides protocol support for the SOCK_STREAM, SOCK_DGRAM, and SOCK_RAW socket types; the SOCK_RAW interface provides access to the IP protocol. ADDRESSING
Internet addresses are four byte quantities, stored in network standard format (on the VAX these are word and byte reversed). The include file <netinet/in.h> defines this address as a discriminated union. Sockets bound to the Internet protocol family utilize the following addressing structure, struct sockaddr_in { short sin_family; u_short sin_port; struct in_addr sin_addr; char sin_zero[8]; }; Sockets may be created with the local address INADDR_ANY to effect ``wildcard'' matching on incoming messages. The address in a connect(2), connectx(2) or sendto(2) call may be given as INADDR_ANY to mean ``this host''. The distinguished address INADDR_BROADCAST is allowed as a shorthand for the broadcast address on the primary network if the first network configured supports broadcast. PROTOCOLS
The Internet protocol family is comprised of the IP transport protocol, Internet Control Message Protocol (ICMP), Transmission Control Proto- col (TCP), and User Datagram Protocol (UDP). TCP is used to support the SOCK_STREAM abstraction while UDP is used to support the SOCK_DGRAM abstraction. A raw interface to IP is available by creating an Internet socket of type SOCK_RAW. The ICMP message protocol is accessible from a raw socket. The 32-bit Internet address contains both network and host parts. It is frequency-encoded; the most-significant bit is clear in Class A addresses, in which the high-order 8 bits are the network number. Class B addresses use the high-order 16 bits as the network field, and Class C addresses have a 24-bit network part. Sites with a cluster of local networks and a connection to the Internet may chose to use a single network number for the cluster; this is done by using subnet addressing. The local (host) portion of the address is further subdi- vided into subnet and host parts. Within a subnet, each subnet appears to be an individual network; externally, the entire cluster appears to be a single, uniform network requiring only a single routing entry. Subnet addressing is enabled and examined by the following ioctl(2) commands on a datagram socket in the Internet domain; they have the same form as the SIOCIFADDR command (see intro(4)). SIOCSIFNETMASK Set interface network mask. The network mask defines the network part of the address; if it contains more of the address than the address type would indicate, then subnets are in use. SIOCGIFNETMASK Get interface network mask. SEE ALSO
ioctl(2), socket(2), icmp(4), intro(4), ip(4), tcp(4), udp(4) "An Introductory 4.3 BSD Interprocess Communication Tutorial", PS1, 7. "An Advanced 4.3 BSD Interprocess Communication Tutorial", PS1, 8. CAVEAT
The Internet protocol support is subject to change as the Internet protocols develop. Users should not depend on details of the current implementation, but rather the services exported. HISTORY
The inet protocol interface appeared in 4.2BSD. 4.2 Berkeley Distribution March 18, 2015 4.2 Berkeley Distribution
Man Page