Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

cltp(4) [netbsd man page]

CLTP(4) 						   BSD Kernel Interfaces Manual 						   CLTP(4)

NAME
cltp -- ISO Connectionless Transport Protocol SYNOPSIS
#include <sys/socket.h> #include <netiso/iso.h> int socket(AF_ISO, SOCK_DGRAM, 0); DESCRIPTION
CLTP is a simple, unreliable datagram protocol which is accessed via the SOCK_DGRAM abstraction for the ISO protocol family. CLTP sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the recv(2) or read(2) and send(2) or write(2) system calls may be used). CLTP address formats are identical to those used by TP. In particular CLTP provides a service selector in addition to the normal ISO NSAP. Note that the CLTP selector space is separate from the TP selector space (i.e. a CLTP selector may not be ``connected'' to a TP selector). Options at the CLNP network level may be used with CLTP; see clnp(4). DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destina- tion address specified and the socket is already connected; [ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been connected; [ENOBUFS] when the system runs out of memory for an internal data structure; [EADDRINUSE] when an attempt is made to create a socket with a selector which has already been allocated; [EADDRNOTAVAIL] when an attempt is made to create a socket with a network address for which no network interface exists. SEE ALSO
getsockopt(2), recv(2), send(2), socket(2), clnp(4), intro(4), iso(4) BSD
June 9, 1993 BSD

Check Out this Related Man Page

udp(4p) 																   udp(4p)

Name
       udp - Internet User Datagram Protocol

Syntax
       #include <sys/socket.h>
       #include <netinet/in.h>

       s = socket(AF_INET, SOCK_DGRAM, 0);

Description
       UDP  is	a  simple,  unreliable datagram protocol that is used to support the SOCK_DGRAM abstraction for the Internet protocol family.  UDP
       sockets are connectionless and are normally used with the and calls, though the call can also be used to fix  the  destination  for  future
       packets (in which case the or and or system calls may be used).

       UDP  address  formats are identical to those used by TCP.  In particular, UDP provides a port identifier in addition to the normal Internet
       address format.	Note that the UDP port space is separate from the TCP port space (for example,	a UDP port may not be ``connected''  to  a
       TCP  port).   In  addition  broadcast  packets  can be sent (assuming the underlying network supports this) by using a reserved ``broadcast
       address''; this address is network interface dependent.	The SO_BROADCAST option must be set on the socket for broadcasting to succeed.

Diagnostics
       A socket operation may fail with one of the following errors returned:

       [EISCONN]      Try to establish a connection on a socket which already has one, or when trying to send  a  datagram  with  the  destination
		      address specified and the socket already connected.

       [ENOTCONN]     Try to send a datagram, but no destination address is specified, and the socket has not been connected.

       [ENOBUFS]      The system runs out of memory for an internal data structure.

       [EADDRINUSE]   An attempt is made to create a socket with a port that has already been allocated.

       [EADDRNOTAVAIL]
		      An attempt is made to create a socket with a network address for which no network interface exists.

See Also
       getsockopt(2), send(2), socket(2) recv(2), intro(4n), inet(4f)

																	   udp(4p)
Man Page