ICP(4) BSD Kernel Interfaces Manual ICP(4)NAME
icp -- ICP-Vortex and Intel Storage RAID driver
icp* at pci? dev ? function ?
ld* at icp? unit ?
icpsp* at icp? unit ?
scsibus* at icpsp?
The icp driver provides support for the newer (post 1997) ICP-Vortex GDT and Intel Storage RAID controllers.
The ld driver provides access to logical devices (disk arrays) presented by the controller. The icpsp driver provides direct access to other
SCSI devices attached to the controller, such as tape or CD-ROM drives.
pci_mem_find: expected mem type 00000000, found 00000002
This message may be displayed during autoconfiguration if the controller's memory is mapped below 1MB in physical address
space. This can be disabled either through changing a setting in the controller's BIOS utility, or changing the position of a
jumper on the board. See your controller's documentation for more information.
SEE ALSO intro(4), ld(4), scsi(4)HISTORY
The icp driver first appeared in NetBSD 1.6, and was based on the FreeBSD and OpenBSD drivers of the same name.
ISA & EISA front-ends and a management interface are needed.
Older PCI boards are not yet supported.
BSD April 20, 2002 BSD
Check Out this Related Man Page
IIR(4) BSD Kernel Interfaces Manual IIR(4)NAME
iir -- Intel Integrated RAID controller and ICP Vortex driver
To compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The iir driver claims to interface with the Intel integrated RAID controller cards, and all versions of the ICP Vortex controllers (including
Controllers supported by the iir driver include:
o Intel RAID Controller SRCMR
o Intel Server RAID Controller U3-l (SRCU31a)
o Intel Server RAID Controller U3-1L (SRCU31La)
o Intel Server RAID Controller U3-2 (SRCU32)
o All past and future releases of Intel and ICP RAID Controllers.
o Intel RAID Controller SRCU21 (discontinued)
o Intel RAID Controller SRCU31 (older revision, not compatible)
o Intel RAID Controller SRCU31L (older revision, not compatible)
The SRCU31 and SRCU31L can be updated via a firmware update available from Intel.
SEE ALSO cam(4), pass(4), xpt(4), camcontrol(8)AUTHORS
The iir driver is supported and maintained by Achim Leubner <Achim_Leubner@adaptec.com>.
This manual page was written by Tom Rhodes <trhodes@FreeBSD.org> and is based on information supplied by the driver authors and the website
of Mike Smith <msmith@FreeBSD.org>.
BSD August 8, 2004 BSD
I have installed Linux 7.2 on a IBM xseries 235 server with 5 scsi hard drives and ServerRaid-5i Ultra320 scsi controller.
I started my installation by configuring the raid controller. I created 2 arrays, raid 1 and raid5. I then proceeded to install Linux and load the drivers.
After the... (2 Replies)
Trying to install Sco openserver on HP Proliant with this scsi controller but no scsi devices detected.
Boot controller is set as the smart array 532 but SCSI diags do not detect any SCSI boot devices during boot sequence
Any help appreciated (2 Replies)
:confused: Hello everybody,
i am totally new to unix, i want to learn unix. i have a server with pIII, 256 mb RAM, two SCSI disk w/o RAID controller.and one IDE CD-ROM Drive.
i heard SCO installs on intel platform. what steps should i take for installing SCO on this machine? can anybody help me... (1 Reply)
I am facing a problem to install sco 5.0.6 in Dell Power Edge SC1420 which raid controller is ultra 320 scsi raid controller .
how/from where to download the ultra 320 scsi raid controller driver for sco 5.0.6.
Plz help with any idea
karzon (1 Reply)
recently we have purchased hp proliant ml350 g5 server and configured raid 5 with hp smartarray p200i sas controller.but i could not found any sas raid controller hp smartarry p200i driver for sco unix 5.0.7 :(.i searched on hp support site,but no use.any one can help. (3 Replies)
To summarize the problem: The "IBM FastT Storage Manager Client v8" shows that our Disk Farm is arranged into 6 logical drives each in a RAID 5 configuration. This software also shows that 5 of the 6 logical drives (from Disk Farm) are in a error state: "Failed Logical Drive - Drive Failure".... (1 Reply)
So today I tried to upgrade a customer from a Proliant with an HPSAS controller to an Intel server with a MEGASAS controller.
First, I downloaded the megasas driver from SCO and installed it on the old system.
Then I created a new Microlite Edge emergency boot cd with the new driver on it.
I... (2 Replies)
We have 2 controllers in storage
controller A is working, configured in Storage
Controller B is not configured in Storage, but Power supply is connected for controller B.
my query is, for some reason if power goes down for Controller A, wheather it will be redundant using Controllers... (1 Reply)
I changed disk controller. Unplugged every disk, inserted another controller card, an IBM M1015. The disks are recognized in BIOS, and the controller card's BIOS shows up. But after that, I drop into GRUB and a prompt. That is all.
How shall I solve this problem? I am thinking of booting from... (2 Replies)
I have a server with a scsi raid controller (for hard drives) and a scsi controller (for tape drive and cd-rom). I am trying to boot from the cd-rom but can't. During boot up, bootable media is detected in the cd-rom but the system will not boot from it. BIOS for the raid controller installs but... (1 Reply)
I'm trying to virtualize an instance of Sco Unix 5.0.5 in VirtualBox (called VM-A) , but sco I have problems set to launch with the new raid controller .
The physical machine has a raid controller adaptec (alad driver) but VirtualBox uses buslogic (blc driver)
What ... (3 Replies)
I have bought this controller.
Simple and fast question: I will put on this controller a external LTO tape,which is terminated with a terminator.
I have to put another terminator on PCI-controller... (1 Reply)
Thank you in advanced,
I had a Buffalo DUO crap out on me that was setup as RAID 0. I dont belive it was the drives but rather the controller in the DUO unit. I bought another external HDD enclosure and was able to fireup the two older DUO drives in it and I think I resembled the RAID... (12 Replies)