|Linux & Unix Commands - Search Man Pages
GEM(4) BSD Kernel Interfaces Manual GEM(4)
gem -- ERI/GEM/GMAC Ethernet device driver
gem* at pci? dev ? function ?
gem* at sbus? slot ? offset ?
Configuration of PHYs may also be necessary. See mii(4).
The gem driver provides support for the GMac Ethernet hardware found mostly in the last
Apple PowerBooks G3s and most G4-based Apple hardware, as well as many Sun UltraSPARCs.
Cards supported by this driver include:
o Sun GEM gigabit ethernet (SX fibre variants)
o Sun ERI 10/100
o Apple GMAC
The GEM family supports hardware checksumming to assist in computing IPv4 TCP checksums.
The gem driver supports this feature of the chip. See ifconfig(8) for information on how to
enable this feature.
bmtphy(4), ifmedia(4), intro(4), mii(4), ifconfig(8)
Sun Microsystems, GEM Gigabit Ethernet ASIC Specification,
Sun Microsystems, Sbus GEM Specification,
The gem device driver appeared in NetBSD 1.6. Support for PCI SX fibre cards was added in
NetBSD 5.0. Support for SBus SX fibre cards was added in NetBSD 5.0.
The gem driver was written by Eduardo Horvath <eeh@NetBSD.org>. SX fibre support was added
by Julian Coleman <jdc@NetBSD.org>. The man page was written by Thomas Klausner
The hardware checksumming support does not support IPv4 UDP, although this was allowed prior
to NetBSD 5.0. Also, the hardware IPv4 TCP receive checksumming support has bugs, so this
On the SX fibre variants of the hardware, the link will stay down if there is a duplex mis-
match. Also, packet transmission may fail when in half-duplex mode.
BSD September 15, 2008 BSD
All times are GMT -4. The time now is 07:46 PM.