FUJBP(4) BSD Kernel Interfaces Manual FUJBP(4)
fujbp, fujhk -- Fujitsu Brightness, Pointer, and Hotkeys
fujbp* at acpi?
fujhk* at acpi?
Some Fujitsu laptops come with vendor-specific ACPI devices to manage the laptop hotkeys
(such as the 'Eco' button), and to control various built-in components (such as the display,
the touchpad, and the speakers). The fujbp and fujhk drivers provide support, through these
ACPI devices, for hotkeys, backlight on/off switch, brightness level control, and pointer
The following sysctl(8) read/write variables are provided (when hardware support is avail-
hw.acpi.fujbp0.brightness Brightness level (integer).
hw.acpi.fujbp0.pointer Pointer switch state (boolean).
hw.acpi.fujhk0.backlight Backlight switch state (boolean).
Please note, however, that future versions of the drivers may remove these sysctl(8) vari-
ables without prior notice.
acpi(4), acpivga(4), sysctl(8), pmf(9), sysmon_pswitch(9)
The fujbp and fujhk drivers appeared in NetBSD 6.0.
Gregoire Sutre <gsutre@NetBSD.org>
Brightness level and backlight switch state should be controlled via wsconsctl(8) instead of
The sysctl(8) variable hw.acpi.fujbp0.pointer should be replaced by a platform-independent
BSD February 20, 2011 BSD