Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

dm(4) [netbsd man page]

DM(4)							   BSD Kernel Interfaces Manual 						     DM(4)

NAME
dm -- Device-mapper disk driver SYNOPSIS
pseudo-device dm DESCRIPTION
The dm driver provides the capability of creating one or more virtual disks based on the target mapping. This document assumes that you're familiar with how to generate kernels, how to properly configure disks and pseudo-devices in a kernel con- figuration file, and how to partition disks. This driver is used by the Linux lvm2tools to create and manage lvm in NetBSD. Currently, the linear, zero, and error targets are implemented. Each component partition should be offset at least 2 sectors from the begin- ning of the component disk. This avoids potential conflicts between the component disk's disklabel and dm's disklabel. In i386 it is offset by 65 sectors, where 63 sectors are the initial boot sectors and 2 sectors are used for the disklabel which is set to be read-only. In order to compile in support for dm, you must add a line similar to the following to your kernel configuration file: pseudo-device dm #device-mapper disk device dm may create linear mapped devices, zero, and error block devices. Zero and error block devices are used mostly for testing. Linear devices are used to create virtual disks with linearly mapped virtual blocks to blocks on real disk. dm Device-mapper devices are controlled through the /dev/mapper/control device. For controlling this device ioctl(2) calls are used. For the implementation of the communication channel, the proplib(3) library is used. The protocol channel is defined as a proplib dictionary with needed values. For more details, look at sys/dev/dm/netbsd-dm.h. Before any device can be used, every device-mapper disk device must be initialized. For initialization one line must be passed to the kernel driver in the form of a proplib dictionary. Every device can have more than one table active. An example for such a line is: 0 10240 linear /dev/wd1a 384 dm The first parameter is the start sector for the table defined with this line, the second is the length in sectors which is described with this table. The third parameter is the target name. All other parts of this line depend on the chosen target. dm For the linear target, there are two additional parameters: The first parameter describes the disk device to which the device-mapper disk is mapped. The second parameter is the offset on this disk from the start of the disk/partition. SEE ALSO
config(1), proplib(3), MAKEDEV(8), dmsetup(8), fsck(8), lvm(8), mount(8), newfs(8) HISTORY
The device-mapper disk driver first appeared in NetBSD 6.0. AUTHORS
Adam Hamsik <haad@NetBSD.org> implemented the device-mapper driver for NetBSD. Brett Lymn <blymn@NetBSD.org>, Reinoud Zandijk <reinoud@NetBSD.org>, and Bill Stouder-Studenmund <wrstuden@NetBSD.org> provided guidance and answered questions about the NetBSD implementation. BUGS
This driver is still work-in-progress--there can be bugs. BSD
August 30, 2008 BSD

Check Out this Related Man Page

chpt(8) 						      System Manager's Manual							   chpt(8)

Name
       chpt - change a disk partition table

Syntax
       /etc/chpt [ -a ] [ -d ] [ -q ] [ -v ] [ [ -px offset size ] ... ] device

Description
       The  command  lets  you alter the partition sizes of a disk pack.  Using you can tailor your system disks and their partitions to suit your
       system's individual needs.

       If you want to create a file system on a partition that has been modified, you must use

       The standard procedure to change a partition table is:

       1. Look at the current partition table using the -q option.

       2. If a file system does not exist on the a partition, create one using the command.

	  If a file system exists on the a partition but does not contain a partition table in its superblock, copy the partition table  from  the
	  driver to the superblock using the command with the -a option.

       3. Change the partition offsets and sizes using the -px option.	You can change all the partitions for one pack on one command line.

       The  device  must be either the a or c partition of the raw device, depending upon where the file system resides.  For example, if the file
       system resides in the a partition of an RM05 in drive 0, device is rhp0a.

       A file system must exist on the a or c partition of the pack.  If you do not have a file system there, create one using

Options
       -a    Copies the partition table in the device driver to the disk pack.

       -d    Copies the default partition table to the disk pack and to the current partition table in the driver.  The default partition table is
	     the table that was built with the disk driver.

       -q    Runs without modifying the partition tables.  This prints the partition table of the specified disk pack.	It prints the default par-
	     tition table in the driver if there is no partition table on the disk pack.

       -v    Prints verbose messages showing the progress of

       -px   Changes the parameters of partition x on the disk pack to the specified offset and size.  x is the partition you are modifying (a, b,
	     c,  d,  e, f, g, or h).  Offset is the new beginning sector, and size is the new total number of sectors of the partition being modi-
	     fied.

Examples
       This example shows how to change the partition table on an RM05 disk pack in drive 1.  The commands in this example change the the size	of
       the h partition to include the g partition.  Comments are in parenthesis to the right of commands.
       % chpt -q /dev/rhp1a	(view partition table)
       /dev/rhp1a
       No partition table found in superblock...
       using default table from device driver.
       Current partition table:
       partition       bottom	    top      size    overlap
	   a		    0	  15883     15884    c
	   b		16416	  49855     33440    c
	   c		    0	 500383    500384    a,b,d,e,f,g,h
	   d	       341696	 357579     15884    c,g
	   e	       358112	 414047     55936    c,g
	   f	       414048	 500287     86240    c,g
	   g	       341696	 500287    158592    c,d,e,f
	   h		49856	 341201    291346    c
       %
       In  all	of  the tables generated by bottom is the offset (starting sector), top is the ending sector, and size is the number of sectors in
       the partition.  The overlap is the other sectors that are partially or entirely included in the partition.
       % bc		   (basic calculator)
       500287-49856	   (top of g minus bottom of h)
       450431
       450431+1 	   (add 1 because it is zero-based)
       450432		   (size of new h partition)
       %

       From the query, you can see that there is no partition table in the superblock of the a partition.  If this is because  there  is  no  file
       system in the a partition, run the command to create one.

       For this example, assume that there is a file system in the a partition of the disk, but the file system does not contain a partition table
       in its superblock.  Therefore, run with the -a option to copy the partition table in the driver to the superblock of the a partition.
       % chpt -a /dev/rhp1a	(add table to a partition)
       %

       Now you have a partition table to change.
       % chpt -v -ph 49856 450432 /dev/rhp1a   (change h)
       /dev/rhp1a
       New partition table:
       partition       bottom  top     size    overlap
	   a		    0	15883	15884  c
	   b		16416	49855	33440  c
	   c		    0  500383  500384  a,b,d,e,f,g,h
	   d	       341696  357579	15884  c,g,h
	   e	       358112  414047	55936  c,g,h
	   f	       414048  500287	86240  c,g,h
	   g	       341696  500287  158592  c,d,e,f,h
	   h		49856  500287  450432  c,d,e,f,g
       %

Caution
       Changing partition tables indiscriminately can result in losing large amounts of data.

       Check for file systems on all the partitions of the disk before using the -p option.  If a  file  system  exists  whose	partition  may	be
       destroyed, copy it to a backup medium.  After you have changed the partitions, restore the backed up file system.

Restrictions
       You must have superuser privileges to use

       You  can not shrink or change the offset of a partition with a file system mounted on it or with an open file descriptor on the entire par-
       tition.

       You can not change the offset of the a partition.

See Also
       ioctl(2), disktab(5), fsck(8), mkfs(8), newfs(8)
       Guide to System Disk Maintenance

																	   chpt(8)
Man Page